Yang Chen | 5e5fe36 | 2023-12-15 16:41:42 +0800 | [diff] [blame] | 1 | LICENSE = "Apache-2.0" |
| 2 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 3 | |
| 4 | inherit allarch systemd obmc-phosphor-systemd |
| 5 | |
| 6 | RDEPENDS:${PN} += "bash" |
| 7 | RDEPENDS:${PN} += "libgpiod-tools" |
| 8 | RDEPENDS:${PN} += "minerva-common-functions" |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://minerva-sys-init.service \ |
| 12 | file://minerva-early-sys-init \ |
Yang Chen | 12acc1d | 2024-01-31 15:21:03 +0800 | [diff] [blame] | 13 | file://minerva-fan-status-monitor \ |
| 14 | file://minerva-fan-status-monitor.service \ |
Yang Chen | 5e5fe36 | 2023-12-15 16:41:42 +0800 | [diff] [blame] | 15 | " |
| 16 | |
| 17 | SYSTEMD_PACKAGES = "${PN}" |
| 18 | SYSTEMD_SERVICE:${PN}:append = " \ |
| 19 | minerva-sys-init.service \ |
Yang Chen | 12acc1d | 2024-01-31 15:21:03 +0800 | [diff] [blame] | 20 | minerva-fan-status-monitor.service \ |
Yang Chen | 5e5fe36 | 2023-12-15 16:41:42 +0800 | [diff] [blame] | 21 | " |
| 22 | |
| 23 | do_install() { |
| 24 | install -d ${D}${libexecdir} |
| 25 | install -m 0755 ${WORKDIR}/minerva-early-sys-init ${D}${libexecdir} |
Yang Chen | 12acc1d | 2024-01-31 15:21:03 +0800 | [diff] [blame] | 26 | install -m 0755 ${WORKDIR}/minerva-fan-status-monitor ${D}${libexecdir} |
Yang Chen | 5e5fe36 | 2023-12-15 16:41:42 +0800 | [diff] [blame] | 27 | } |
| 28 | |