blob: 1b458fa2df9144e9108bc0cdd5d83a6306ed255e [file] [log] [blame]
Andrew Geissler8f840682023-07-21 09:09:43 -05001# SPDX-License-Identifier: MIT
2# Copyright (C) 2023 iris-GmbH infrared & intelligent sensors
3
4SUMMARY = "pyproject-api aims to abstract away interaction with pyproject.toml style projects in a flexible way."
5HOMEPAGE = "https://pyproject-api.readthedocs.io"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=11610a9d8fd95649cf8159be12b98cb7"
8
9SRC_URI[sha256sum] = "435f46547a9ff22cf4208ee274fca3e2869aeb062a4834adfc99a4dd64af3cf9"
10
11PYPI_PACKAGE = "pyproject_api"
12
13BBCLASSEXTEND = "native nativesdk"
14inherit pypi python_hatchling
15
16DEPENDS += "\
17 ${PYTHON_PN}-hatch-vcs-native \
18"
19
20RDEPENDS:${PN} += "\
21 ${PYTHON_PN}-packaging \
22 ${PYTHON_PN}-tomli \
23"