Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame^] | 1 | # SPDX-License-Identifier: MIT |
| 2 | # Copyright (C) 2023 iris-GmbH infrared & intelligent sensors |
| 3 | |
| 4 | SUMMARY = "pyproject-api aims to abstract away interaction with pyproject.toml style projects in a flexible way." |
| 5 | HOMEPAGE = "https://pyproject-api.readthedocs.io" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=11610a9d8fd95649cf8159be12b98cb7" |
| 8 | |
| 9 | SRC_URI[sha256sum] = "435f46547a9ff22cf4208ee274fca3e2869aeb062a4834adfc99a4dd64af3cf9" |
| 10 | |
| 11 | PYPI_PACKAGE = "pyproject_api" |
| 12 | |
| 13 | BBCLASSEXTEND = "native nativesdk" |
| 14 | inherit pypi python_hatchling |
| 15 | |
| 16 | DEPENDS += "\ |
| 17 | ${PYTHON_PN}-hatch-vcs-native \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS:${PN} += "\ |
| 21 | ${PYTHON_PN}-packaging \ |
| 22 | ${PYTHON_PN}-tomli \ |
| 23 | " |