blob: 263acd06c72ae012afd7632191d0f9fff14a780a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A pure Python netlink and Linux network configuration library"
Andrew Geissler8f840682023-07-21 09:09:43 -05002LICENSE = "GPL-2.0-or-later | Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=dccbff78d7d79ae7e53953d43445c6e6 \
4 file://LICENSE.GPL-2.0-or-later;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://LICENSE.Apache-2.0;md5=34281e312165f843a2b7d1f114fe65ce"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
Andrew Geissler8f840682023-07-21 09:09:43 -05007SRC_URI[sha256sum] = "b69d82f140b0774317d7ba40f6c5fa1d755098ba3f3eb619982d16e750dc631a"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
9inherit setuptools3 pypi ptest
10
Patrick Williams213cb262021-08-07 19:21:33 -050011RDEPENDS:${PN} += " \
Patrick Williamsb542dec2023-06-09 01:26:37 -050012 python3-ctypes \
13 python3-distutils \
14 python3-io \
15 python3-json \
16 python3-fcntl \
17 python3-logging \
18 python3-multiprocessing \
19 python3-pickle \
20 python3-pkgutil \
21 python3-pprint \
22 python3-shell \
23 python3-unixadmin \
Andrew Geissler82c905d2020-04-13 13:39:40 -050024"
25
26SRC_URI += " \
Patrick Williamsb542dec2023-06-09 01:26:37 -050027 file://run-ptest \
Andrew Geissler82c905d2020-04-13 13:39:40 -050028"
29
Patrick Williams213cb262021-08-07 19:21:33 -050030RDEPENDS:${PN}-ptest += " \
Patrick Williamsb542dec2023-06-09 01:26:37 -050031 python3-pytest \
32 python3-fcntl \
Andrew Geissler82c905d2020-04-13 13:39:40 -050033"
34
35do_install_ptest() {
Patrick Williamsb542dec2023-06-09 01:26:37 -050036 install -d ${D}${PTEST_PATH}/tests
37 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
Andrew Geissler82c905d2020-04-13 13:39:40 -050038}