blob: 2e9563186e892204852b0e14ff2254850bfaca5c [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7inherit linux-kernel-base kernel-module-split
8
9COMPATIBLE_HOST = ".*-linux"
10
11KERNEL_PACKAGE_NAME ??= "kernel"
12KERNEL_DEPLOYSUBDIR ??= "${@ "" if (d.getVar("KERNEL_PACKAGE_NAME") == "kernel") else d.getVar("KERNEL_PACKAGE_NAME") }"
13
14PROVIDES += "virtual/kernel"
15DEPENDS += "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}gcc kmod-native bc-native bison-native"
16DEPENDS += "${@bb.utils.contains("INITRAMFS_FSTYPES", "cpio.lzo", "lzop-native", "", d)}"
17DEPENDS += "${@bb.utils.contains("INITRAMFS_FSTYPES", "cpio.lz4", "lz4-native", "", d)}"
18DEPENDS += "${@bb.utils.contains("INITRAMFS_FSTYPES", "cpio.zst", "zstd-native", "", d)}"
19PACKAGE_WRITE_DEPS += "depmodwrapper-cross"
20
21do_deploy[depends] += "depmodwrapper-cross:do_populate_sysroot gzip-native:do_populate_sysroot"
22do_clean[depends] += "make-mod-scripts:do_clean"
23
24CVE_PRODUCT ?= "linux_kernel"
25
26S = "${STAGING_KERNEL_DIR}"
27B = "${WORKDIR}/build"
28KBUILD_OUTPUT = "${B}"
29OE_TERMINAL_EXPORTS += "KBUILD_OUTPUT"
30
31# we include gcc above, we dont need virtual/libc
32INHIBIT_DEFAULT_DEPS = "1"
33
34KERNEL_IMAGETYPE ?= "zImage"
35INITRAMFS_IMAGE ?= ""
Patrick Williams92b42cb2022-09-03 06:53:57 -050036INITRAMFS_TASK ?= ""
37INITRAMFS_IMAGE_BUNDLE ?= ""
38INITRAMFS_DEPLOY_DIR_IMAGE ?= "${DEPLOY_DIR_IMAGE}"
39INITRAMFS_MULTICONFIG ?= ""
40
41# KERNEL_VERSION is extracted from source code. It is evaluated as
42# None for the first parsing, since the code has not been fetched.
43# After the code is fetched, it will be evaluated as real version
44# number and cause kernel to be rebuilt. To avoid this, make
45# KERNEL_VERSION_NAME and KERNEL_VERSION_PKG_NAME depend on
46# LINUX_VERSION which is a constant.
47KERNEL_VERSION_NAME = "${@d.getVar('KERNEL_VERSION') or ""}"
48KERNEL_VERSION_NAME[vardepvalue] = "${LINUX_VERSION}"
49KERNEL_VERSION_PKG_NAME = "${@legitimize_package_name(d.getVar('KERNEL_VERSION'))}"
50KERNEL_VERSION_PKG_NAME[vardepvalue] = "${LINUX_VERSION}"
51
52python __anonymous () {
53 pn = d.getVar("PN")
54 kpn = d.getVar("KERNEL_PACKAGE_NAME")
55
56 # XXX Remove this after bug 11905 is resolved
57 # FILES:${KERNEL_PACKAGE_NAME}-dev doesn't expand correctly
58 if kpn == pn:
59 bb.warn("Some packages (E.g. *-dev) might be missing due to "
60 "bug 11905 (variable KERNEL_PACKAGE_NAME == PN)")
61
62 # The default kernel recipe builds in a shared location defined by
63 # bitbake/distro confs: STAGING_KERNEL_DIR and STAGING_KERNEL_BUILDDIR.
64 # Set these variables to directories under ${WORKDIR} in alternate
65 # kernel recipes (I.e. where KERNEL_PACKAGE_NAME != kernel) so that they
66 # may build in parallel with the default kernel without clobbering.
67 if kpn != "kernel":
68 workdir = d.getVar("WORKDIR")
69 sourceDir = os.path.join(workdir, 'kernel-source')
70 artifactsDir = os.path.join(workdir, 'kernel-build-artifacts')
71 d.setVar("STAGING_KERNEL_DIR", sourceDir)
72 d.setVar("STAGING_KERNEL_BUILDDIR", artifactsDir)
73
74 # Merge KERNEL_IMAGETYPE and KERNEL_ALT_IMAGETYPE into KERNEL_IMAGETYPES
75 type = d.getVar('KERNEL_IMAGETYPE') or ""
76 alttype = d.getVar('KERNEL_ALT_IMAGETYPE') or ""
77 types = d.getVar('KERNEL_IMAGETYPES') or ""
78 if type not in types.split():
79 types = (type + ' ' + types).strip()
80 if alttype not in types.split():
81 types = (alttype + ' ' + types).strip()
82 d.setVar('KERNEL_IMAGETYPES', types)
83
84 # KERNEL_IMAGETYPES may contain a mixture of image types supported directly
85 # by the kernel build system and types which are created by post-processing
86 # the output of the kernel build system (e.g. compressing vmlinux ->
87 # vmlinux.gz in kernel_do_transform_kernel()).
88 # KERNEL_IMAGETYPE_FOR_MAKE should contain only image types supported
89 # directly by the kernel build system.
90 if not d.getVar('KERNEL_IMAGETYPE_FOR_MAKE'):
91 typeformake = set()
92 for type in types.split():
93 if type == 'vmlinux.gz':
94 type = 'vmlinux'
95 typeformake.add(type)
96
97 d.setVar('KERNEL_IMAGETYPE_FOR_MAKE', ' '.join(sorted(typeformake)))
98
99 kname = d.getVar('KERNEL_PACKAGE_NAME') or "kernel"
100 imagedest = d.getVar('KERNEL_IMAGEDEST')
101
102 for type in types.split():
103 if bb.data.inherits_class('nopackages', d):
104 continue
105 typelower = type.lower()
106 d.appendVar('PACKAGES', ' %s-image-%s' % (kname, typelower))
107 d.setVar('FILES:' + kname + '-image-' + typelower, '/' + imagedest + '/' + type + '-${KERNEL_VERSION_NAME}' + ' /' + imagedest + '/' + type)
108 d.appendVar('RDEPENDS:%s-image' % kname, ' %s-image-%s (= ${EXTENDPKGV})' % (kname, typelower))
109 splitmods = d.getVar("KERNEL_SPLIT_MODULES")
110 if splitmods != '1':
111 d.appendVar('RDEPENDS:%s-image' % kname, ' %s-modules (= ${EXTENDPKGV})' % kname)
112 d.appendVar('RDEPENDS:%s-image-%s' % (kname, typelower), ' %s-modules-${KERNEL_VERSION_PKG_NAME} (= ${EXTENDPKGV})' % kname)
113 d.setVar('PKG:%s-modules' % kname, '%s-modules-${KERNEL_VERSION_PKG_NAME}' % kname)
114 d.appendVar('RPROVIDES:%s-modules' % kname, '%s-modules-${KERNEL_VERSION_PKG_NAME}' % kname)
115
116 d.setVar('PKG:%s-image-%s' % (kname,typelower), '%s-image-%s-${KERNEL_VERSION_PKG_NAME}' % (kname, typelower))
117 d.setVar('ALLOW_EMPTY:%s-image-%s' % (kname, typelower), '1')
118 d.prependVar('pkg_postinst:%s-image-%s' % (kname,typelower), """set +e
119if [ -n "$D" ]; then
120 ln -sf %s-${KERNEL_VERSION} $D/${KERNEL_IMAGEDEST}/%s > /dev/null 2>&1
121else
122 ln -sf %s-${KERNEL_VERSION} ${KERNEL_IMAGEDEST}/%s > /dev/null 2>&1
123 if [ $? -ne 0 ]; then
124 echo "Filesystem on ${KERNEL_IMAGEDEST}/ doesn't support symlinks, falling back to copied image (%s)."
125 install -m 0644 ${KERNEL_IMAGEDEST}/%s-${KERNEL_VERSION} ${KERNEL_IMAGEDEST}/%s
126 fi
127fi
128set -e
129""" % (type, type, type, type, type, type, type))
130 d.setVar('pkg_postrm:%s-image-%s' % (kname,typelower), """set +e
131if [ -f "${KERNEL_IMAGEDEST}/%s" -o -L "${KERNEL_IMAGEDEST}/%s" ]; then
132 rm -f ${KERNEL_IMAGEDEST}/%s > /dev/null 2>&1
133fi
134set -e
135""" % (type, type, type))
136
137
138 image = d.getVar('INITRAMFS_IMAGE')
139 # If the INTIRAMFS_IMAGE is set but the INITRAMFS_IMAGE_BUNDLE is set to 0,
140 # the do_bundle_initramfs does nothing, but the INITRAMFS_IMAGE is built
141 # standalone for use by wic and other tools.
142 if image:
143 if d.getVar('INITRAMFS_MULTICONFIG'):
144 d.appendVarFlag('do_bundle_initramfs', 'mcdepends', ' mc::${INITRAMFS_MULTICONFIG}:${INITRAMFS_IMAGE}:do_image_complete')
145 else:
146 d.appendVarFlag('do_bundle_initramfs', 'depends', ' ${INITRAMFS_IMAGE}:do_image_complete')
147 if image and bb.utils.to_boolean(d.getVar('INITRAMFS_IMAGE_BUNDLE')):
148 bb.build.addtask('do_transform_bundled_initramfs', 'do_deploy', 'do_bundle_initramfs', d)
149
150 # NOTE: setting INITRAMFS_TASK is for backward compatibility
151 # The preferred method is to set INITRAMFS_IMAGE, because
152 # this INITRAMFS_TASK has circular dependency problems
153 # if the initramfs requires kernel modules
154 image_task = d.getVar('INITRAMFS_TASK')
155 if image_task:
156 d.appendVarFlag('do_configure', 'depends', ' ${INITRAMFS_TASK}')
157}
158
159# Here we pull in all various kernel image types which we support.
160#
161# In case you're wondering why kernel.bbclass inherits the other image
162# types instead of the other way around, the reason for that is to
163# maintain compatibility with various currently existing meta-layers.
164# By pulling in the various kernel image types here, we retain the
165# original behavior of kernel.bbclass, so no meta-layers should get
166# broken.
167#
168# KERNEL_CLASSES by default pulls in kernel-uimage.bbclass, since this
169# used to be the default behavior when only uImage was supported. This
170# variable can be appended by users who implement support for new kernel
171# image types.
172
173KERNEL_CLASSES ?= " kernel-uimage "
174inherit ${KERNEL_CLASSES}
175
176# Old style kernels may set ${S} = ${WORKDIR}/git for example
177# We need to move these over to STAGING_KERNEL_DIR. We can't just
178# create the symlink in advance as the git fetcher can't cope with
179# the symlink.
180do_unpack[cleandirs] += " ${S} ${STAGING_KERNEL_DIR} ${B} ${STAGING_KERNEL_BUILDDIR}"
181do_clean[cleandirs] += " ${S} ${STAGING_KERNEL_DIR} ${B} ${STAGING_KERNEL_BUILDDIR}"
182python do_symlink_kernsrc () {
183 s = d.getVar("S")
Patrick Williams92b42cb2022-09-03 06:53:57 -0500184 kernsrc = d.getVar("STAGING_KERNEL_DIR")
185 if s != kernsrc:
186 bb.utils.mkdirhier(kernsrc)
187 bb.utils.remove(kernsrc, recurse=True)
Andrew Geissler8f840682023-07-21 09:09:43 -0500188 if s[-1] == '/':
189 # drop trailing slash, so that os.symlink(kernsrc, s) doesn't use s as
190 # directory name and fail
191 s = s[:-1]
Patrick Williams92b42cb2022-09-03 06:53:57 -0500192 if d.getVar("EXTERNALSRC"):
193 # With EXTERNALSRC S will not be wiped so we can symlink to it
194 os.symlink(s, kernsrc)
195 else:
196 import shutil
197 shutil.move(s, kernsrc)
198 os.symlink(kernsrc, s)
199}
200# do_patch is normally ordered before do_configure, but
201# externalsrc.bbclass deletes do_patch, breaking the dependency of
202# do_configure on do_symlink_kernsrc.
203addtask symlink_kernsrc before do_patch do_configure after do_unpack
204
205inherit kernel-arch deploy
206
207PACKAGES_DYNAMIC += "^${KERNEL_PACKAGE_NAME}-module-.*"
208PACKAGES_DYNAMIC += "^${KERNEL_PACKAGE_NAME}-image-.*"
209PACKAGES_DYNAMIC += "^${KERNEL_PACKAGE_NAME}-firmware-.*"
210
211export OS = "${TARGET_OS}"
212export CROSS_COMPILE = "${TARGET_PREFIX}"
Patrick Williams92b42cb2022-09-03 06:53:57 -0500213
214KERNEL_RELEASE ?= "${KERNEL_VERSION}"
215
216# The directory where built kernel lies in the kernel tree
217KERNEL_OUTPUT_DIR ?= "arch/${ARCH}/boot"
218KERNEL_IMAGEDEST ?= "boot"
Andrew Geissler028142b2023-05-05 11:29:21 -0500219KERNEL_DTBDEST ?= "${KERNEL_IMAGEDEST}"
Patrick Williamse760df82023-05-26 11:10:49 -0500220KERNEL_DTBVENDORED ?= "0"
Patrick Williams92b42cb2022-09-03 06:53:57 -0500221
222#
223# configuration
224#
225export CMDLINE_CONSOLE = "console=${@d.getVar("KERNEL_CONSOLE") or "ttyS0"}"
226
227KERNEL_VERSION = "${@get_kernelversion_headers('${B}')}"
228
229# kernels are generally machine specific
230PACKAGE_ARCH = "${MACHINE_ARCH}"
231
232# U-Boot support
233UBOOT_ENTRYPOINT ?= "20008000"
234UBOOT_LOADADDRESS ?= "${UBOOT_ENTRYPOINT}"
235
236# Some Linux kernel configurations need additional parameters on the command line
237KERNEL_EXTRA_ARGS ?= ""
238
Patrick Williams520786c2023-06-25 16:20:36 -0500239EXTRA_OEMAKE += ' CC="${KERNEL_CC}" LD="${KERNEL_LD}" OBJCOPY="${KERNEL_OBJCOPY}" STRIP="${KERNEL_STRIP}"'
Patrick Williams92b42cb2022-09-03 06:53:57 -0500240EXTRA_OEMAKE += ' HOSTCC="${BUILD_CC}" HOSTCFLAGS="${BUILD_CFLAGS}" HOSTLDFLAGS="${BUILD_LDFLAGS}" HOSTCPP="${BUILD_CPP}"'
Patrick Williamsb542dec2023-06-09 01:26:37 -0500241EXTRA_OEMAKE += ' HOSTCXX="${BUILD_CXX}" HOSTCXXFLAGS="${BUILD_CXXFLAGS}"'
Patrick Williams92b42cb2022-09-03 06:53:57 -0500242
243KERNEL_ALT_IMAGETYPE ??= ""
244
245copy_initramfs() {
246 echo "Copying initramfs into ./usr ..."
247 # In case the directory is not created yet from the first pass compile:
248 mkdir -p ${B}/usr
249 # Find and use the first initramfs image archive type we find
250 rm -f ${B}/usr/${INITRAMFS_IMAGE_NAME}.cpio
251 for img in cpio cpio.gz cpio.lz4 cpio.lzo cpio.lzma cpio.xz cpio.zst; do
252 if [ -e "${INITRAMFS_DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE_NAME}.$img" ]; then
253 cp ${INITRAMFS_DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE_NAME}.$img ${B}/usr/.
254 case $img in
255 *gz)
256 echo "gzip decompressing image"
257 gunzip -f ${B}/usr/${INITRAMFS_IMAGE_NAME}.$img
258 break
259 ;;
260 *lz4)
261 echo "lz4 decompressing image"
262 lz4 -df ${B}/usr/${INITRAMFS_IMAGE_NAME}.$img ${B}/usr/${INITRAMFS_IMAGE_NAME}.cpio
263 break
264 ;;
265 *lzo)
266 echo "lzo decompressing image"
267 lzop -df ${B}/usr/${INITRAMFS_IMAGE_NAME}.$img
268 break
269 ;;
270 *lzma)
271 echo "lzma decompressing image"
272 lzma -df ${B}/usr/${INITRAMFS_IMAGE_NAME}.$img
273 break
274 ;;
275 *xz)
276 echo "xz decompressing image"
277 xz -df ${B}/usr/${INITRAMFS_IMAGE_NAME}.$img
278 break
279 ;;
280 *zst)
281 echo "zst decompressing image"
282 zstd -df ${B}/usr/${INITRAMFS_IMAGE_NAME}.$img
283 break
284 ;;
285 esac
286 break
287 fi
288 done
289 # Verify that the above loop found a initramfs, fail otherwise
290 [ -f ${B}/usr/${INITRAMFS_IMAGE_NAME}.cpio ] && echo "Finished copy of initramfs into ./usr" || die "Could not find any ${INITRAMFS_DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE_NAME}.cpio{.gz|.lz4|.lzo|.lzma|.xz|.zst) for bundling; INITRAMFS_IMAGE_NAME might be wrong."
291}
292
293do_bundle_initramfs () {
294 if [ ! -z "${INITRAMFS_IMAGE}" -a x"${INITRAMFS_IMAGE_BUNDLE}" = x1 ]; then
295 echo "Creating a kernel image with a bundled initramfs..."
296 copy_initramfs
297 # Backing up kernel image relies on its type(regular file or symbolic link)
298 tmp_path=""
299 for imageType in ${KERNEL_IMAGETYPE_FOR_MAKE} ; do
300 if [ -h ${KERNEL_OUTPUT_DIR}/$imageType ] ; then
301 linkpath=`readlink -n ${KERNEL_OUTPUT_DIR}/$imageType`
302 realpath=`readlink -fn ${KERNEL_OUTPUT_DIR}/$imageType`
303 mv -f $realpath $realpath.bak
304 tmp_path=$tmp_path" "$imageType"#"$linkpath"#"$realpath
305 elif [ -f ${KERNEL_OUTPUT_DIR}/$imageType ]; then
306 mv -f ${KERNEL_OUTPUT_DIR}/$imageType ${KERNEL_OUTPUT_DIR}/$imageType.bak
307 tmp_path=$tmp_path" "$imageType"##"
308 fi
309 done
310 use_alternate_initrd=CONFIG_INITRAMFS_SOURCE=${B}/usr/${INITRAMFS_IMAGE_NAME}.cpio
311 kernel_do_compile
312 # Restoring kernel image
313 for tp in $tmp_path ; do
314 imageType=`echo $tp|cut -d "#" -f 1`
315 linkpath=`echo $tp|cut -d "#" -f 2`
316 realpath=`echo $tp|cut -d "#" -f 3`
317 if [ -n "$realpath" ]; then
318 mv -f $realpath $realpath.initramfs
319 mv -f $realpath.bak $realpath
320 ln -sf $linkpath.initramfs ${B}/${KERNEL_OUTPUT_DIR}/$imageType.initramfs
321 else
322 mv -f ${KERNEL_OUTPUT_DIR}/$imageType ${KERNEL_OUTPUT_DIR}/$imageType.initramfs
323 mv -f ${KERNEL_OUTPUT_DIR}/$imageType.bak ${KERNEL_OUTPUT_DIR}/$imageType
324 fi
325 done
326 fi
327}
328do_bundle_initramfs[dirs] = "${B}"
329
330kernel_do_transform_bundled_initramfs() {
331 # vmlinux.gz is not built by kernel
332 if (echo "${KERNEL_IMAGETYPES}" | grep -wq "vmlinux\.gz"); then
333 gzip -9cn < ${KERNEL_OUTPUT_DIR}/vmlinux.initramfs > ${KERNEL_OUTPUT_DIR}/vmlinux.gz.initramfs
334 fi
335}
336do_transform_bundled_initramfs[dirs] = "${B}"
337
Patrick Williams520786c2023-06-25 16:20:36 -0500338python do_package:prepend () {
339 os.environ['STRIP'] = d.getVar('KERNEL_STRIP')
340}
341
Patrick Williams92b42cb2022-09-03 06:53:57 -0500342python do_devshell:prepend () {
343 os.environ["LDFLAGS"] = ''
344}
345
346addtask bundle_initramfs after do_install before do_deploy
347
348KERNEL_DEBUG_TIMESTAMPS ??= "0"
349
350kernel_do_compile() {
351 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
352
353 # setup native pkg-config variables (kconfig scripts call pkg-config directly, cannot generically be overriden to pkg-config-native)
354 export PKG_CONFIG_DIR="${STAGING_DIR_NATIVE}${libdir_native}/pkgconfig"
355 export PKG_CONFIG_PATH="$PKG_CONFIG_DIR:${STAGING_DATADIR_NATIVE}/pkgconfig"
356 export PKG_CONFIG_LIBDIR="$PKG_CONFIG_DIR"
357 export PKG_CONFIG_SYSROOT_DIR=""
358
Andrew Geissler8f840682023-07-21 09:09:43 -0500359 # for newer kernels (5.19+) there's a dedicated variable
360 export HOSTPKG_CONFIG="pkg-config-native"
361
Patrick Williams92b42cb2022-09-03 06:53:57 -0500362 if [ "${KERNEL_DEBUG_TIMESTAMPS}" != "1" ]; then
363 # kernel sources do not use do_unpack, so SOURCE_DATE_EPOCH may not
364 # be set....
365 if [ "${SOURCE_DATE_EPOCH}" = "" -o "${SOURCE_DATE_EPOCH}" = "0" ]; then
366 # The source directory is not necessarily a git repository, so we
367 # specify the git-dir to ensure that git does not query a
368 # repository in any parent directory.
369 SOURCE_DATE_EPOCH=`git --git-dir="${S}/.git" log -1 --pretty=%ct 2>/dev/null || echo "${REPRODUCIBLE_TIMESTAMP_ROOTFS}"`
370 fi
371
372 ts=`LC_ALL=C date -d @$SOURCE_DATE_EPOCH`
373 export KBUILD_BUILD_TIMESTAMP="$ts"
374 export KCONFIG_NOTIMESTAMP=1
375 bbnote "KBUILD_BUILD_TIMESTAMP: $ts"
Andrew Geissler517393d2023-01-13 08:55:19 -0600376 else
377 ts=`LC_ALL=C date`
378 export KBUILD_BUILD_TIMESTAMP="$ts"
379 bbnote "KBUILD_BUILD_TIMESTAMP: $ts"
Patrick Williams92b42cb2022-09-03 06:53:57 -0500380 fi
381 # The $use_alternate_initrd is only set from
382 # do_bundle_initramfs() This variable is specifically for the
383 # case where we are making a second pass at the kernel
384 # compilation and we want to force the kernel build to use a
385 # different initramfs image. The way to do that in the kernel
386 # is to specify:
387 # make ...args... CONFIG_INITRAMFS_SOURCE=some_other_initramfs.cpio
388 if [ "$use_alternate_initrd" = "" ] && [ "${INITRAMFS_TASK}" != "" ] ; then
389 # The old style way of copying an prebuilt image and building it
390 # is turned on via INTIRAMFS_TASK != ""
391 copy_initramfs
392 use_alternate_initrd=CONFIG_INITRAMFS_SOURCE=${B}/usr/${INITRAMFS_IMAGE_NAME}.cpio
393 fi
394 for typeformake in ${KERNEL_IMAGETYPE_FOR_MAKE} ; do
Patrick Williams8e7b46e2023-05-01 14:19:06 -0500395 oe_runmake ${PARALLEL_MAKE} ${typeformake} ${KERNEL_EXTRA_ARGS} $use_alternate_initrd
Patrick Williams92b42cb2022-09-03 06:53:57 -0500396 done
397}
398
399kernel_do_transform_kernel() {
400 # vmlinux.gz is not built by kernel
401 if (echo "${KERNEL_IMAGETYPES}" | grep -wq "vmlinux\.gz"); then
402 mkdir -p "${KERNEL_OUTPUT_DIR}"
403 gzip -9cn < ${B}/vmlinux > "${KERNEL_OUTPUT_DIR}/vmlinux.gz"
404 fi
405}
406do_transform_kernel[dirs] = "${B}"
407addtask transform_kernel after do_compile before do_install
408
409do_compile_kernelmodules() {
410 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
411 if [ "${KERNEL_DEBUG_TIMESTAMPS}" != "1" ]; then
412 # kernel sources do not use do_unpack, so SOURCE_DATE_EPOCH may not
413 # be set....
414 if [ "${SOURCE_DATE_EPOCH}" = "" -o "${SOURCE_DATE_EPOCH}" = "0" ]; then
415 # The source directory is not necessarily a git repository, so we
416 # specify the git-dir to ensure that git does not query a
417 # repository in any parent directory.
418 SOURCE_DATE_EPOCH=`git --git-dir="${S}/.git" log -1 --pretty=%ct 2>/dev/null || echo "${REPRODUCIBLE_TIMESTAMP_ROOTFS}"`
419 fi
420
421 ts=`LC_ALL=C date -d @$SOURCE_DATE_EPOCH`
422 export KBUILD_BUILD_TIMESTAMP="$ts"
423 export KCONFIG_NOTIMESTAMP=1
424 bbnote "KBUILD_BUILD_TIMESTAMP: $ts"
Andrew Geissler517393d2023-01-13 08:55:19 -0600425 else
426 ts=`LC_ALL=C date`
427 export KBUILD_BUILD_TIMESTAMP="$ts"
428 bbnote "KBUILD_BUILD_TIMESTAMP: $ts"
Patrick Williams92b42cb2022-09-03 06:53:57 -0500429 fi
430 if (grep -q -i -e '^CONFIG_MODULES=y$' ${B}/.config); then
431 oe_runmake -C ${B} ${PARALLEL_MAKE} modules ${KERNEL_EXTRA_ARGS}
432
Andrew Geissler8f840682023-07-21 09:09:43 -0500433 # Module.symvers gets updated during the
Patrick Williams92b42cb2022-09-03 06:53:57 -0500434 # building of the kernel modules. We need to
435 # update this in the shared workdir since some
436 # external kernel modules has a dependency on
437 # other kernel modules and will look at this
438 # file to do symbol lookups
439 cp ${B}/Module.symvers ${STAGING_KERNEL_BUILDDIR}/
440 # 5.10+ kernels have module.lds that we need to copy for external module builds
441 if [ -e "${B}/scripts/module.lds" ]; then
442 install -Dm 0644 ${B}/scripts/module.lds ${STAGING_KERNEL_BUILDDIR}/scripts/module.lds
443 fi
444 else
445 bbnote "no modules to compile"
446 fi
447}
448addtask compile_kernelmodules after do_compile before do_strip
449
450kernel_do_install() {
451 #
452 # First install the modules
453 #
454 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
455 if (grep -q -i -e '^CONFIG_MODULES=y$' .config); then
456 oe_runmake DEPMOD=echo MODLIB=${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION} INSTALL_FW_PATH=${D}${nonarch_base_libdir}/firmware modules_install
457 rm "${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/build"
458 rm "${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/source"
Andrew Geissler517393d2023-01-13 08:55:19 -0600459 # Remove empty module directories to prevent QA issues
460 find "${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel" -type d -empty -delete
Patrick Williams92b42cb2022-09-03 06:53:57 -0500461 else
462 bbnote "no modules to install"
463 fi
464
465 #
466 # Install various kernel output (zImage, map file, config, module support files)
467 #
468 install -d ${D}/${KERNEL_IMAGEDEST}
469
470 #
471 # When including an initramfs bundle inside a FIT image, the fitImage is created after the install task
472 # by do_assemble_fitimage_initramfs.
473 # This happens after the generation of the initramfs bundle (done by do_bundle_initramfs).
474 # So, at the level of the install task we should not try to install the fitImage. fitImage is still not
475 # generated yet.
476 # After the generation of the fitImage, the deploy task copies the fitImage from the build directory to
477 # the deploy folder.
478 #
479
480 for imageType in ${KERNEL_IMAGETYPES} ; do
481 if [ $imageType != "fitImage" ] || [ "${INITRAMFS_IMAGE_BUNDLE}" != "1" ] ; then
482 install -m 0644 ${KERNEL_OUTPUT_DIR}/$imageType ${D}/${KERNEL_IMAGEDEST}/$imageType-${KERNEL_VERSION}
483 fi
484 done
485
486 install -m 0644 System.map ${D}/${KERNEL_IMAGEDEST}/System.map-${KERNEL_VERSION}
487 install -m 0644 .config ${D}/${KERNEL_IMAGEDEST}/config-${KERNEL_VERSION}
488 install -m 0644 vmlinux ${D}/${KERNEL_IMAGEDEST}/vmlinux-${KERNEL_VERSION}
489 [ -e Module.symvers ] && install -m 0644 Module.symvers ${D}/${KERNEL_IMAGEDEST}/Module.symvers-${KERNEL_VERSION}
Patrick Williams92b42cb2022-09-03 06:53:57 -0500490}
491
492# Must be ran no earlier than after do_kernel_checkout or else Makefile won't be in ${S}/Makefile
493do_kernel_version_sanity_check() {
494 if [ "x${KERNEL_VERSION_SANITY_SKIP}" = "x1" ]; then
495 exit 0
496 fi
497
498 # The Makefile determines the kernel version shown at runtime
499 # Don't use KERNEL_VERSION because the headers it grabs the version from aren't generated until do_compile
500 VERSION=$(grep "^VERSION =" ${S}/Makefile | sed s/.*=\ *//)
501 PATCHLEVEL=$(grep "^PATCHLEVEL =" ${S}/Makefile | sed s/.*=\ *//)
502 SUBLEVEL=$(grep "^SUBLEVEL =" ${S}/Makefile | sed s/.*=\ *//)
503 EXTRAVERSION=$(grep "^EXTRAVERSION =" ${S}/Makefile | sed s/.*=\ *//)
504
505 # Build a string for regex and a plain version string
506 reg="^${VERSION}\.${PATCHLEVEL}"
507 vers="${VERSION}.${PATCHLEVEL}"
508 if [ -n "${SUBLEVEL}" ]; then
509 # Ignoring a SUBLEVEL of zero is fine
510 if [ "${SUBLEVEL}" = "0" ]; then
511 reg="${reg}(\.${SUBLEVEL})?"
512 else
513 reg="${reg}\.${SUBLEVEL}"
514 vers="${vers}.${SUBLEVEL}"
515 fi
516 fi
517 vers="${vers}${EXTRAVERSION}"
518 reg="${reg}${EXTRAVERSION}"
519
520 if [ -z `echo ${PV} | grep -E "${reg}"` ]; then
521 bbfatal "Package Version (${PV}) does not match of kernel being built (${vers}). Please update the PV variable to match the kernel source or set KERNEL_VERSION_SANITY_SKIP=\"1\" in your recipe."
522 fi
523 exit 0
524}
525
526addtask shared_workdir after do_compile before do_compile_kernelmodules
527addtask shared_workdir_setscene
528
529do_shared_workdir_setscene () {
530 exit 1
531}
532
533emit_depmod_pkgdata() {
534 # Stash data for depmod
535 install -d ${PKGDESTWORK}/${KERNEL_PACKAGE_NAME}-depmod/
536 echo "${KERNEL_VERSION}" > ${PKGDESTWORK}/${KERNEL_PACKAGE_NAME}-depmod/${KERNEL_PACKAGE_NAME}-abiversion
537 cp ${B}/System.map ${PKGDESTWORK}/${KERNEL_PACKAGE_NAME}-depmod/System.map-${KERNEL_VERSION}
538}
539
540PACKAGEFUNCS += "emit_depmod_pkgdata"
541
542do_shared_workdir[cleandirs] += " ${STAGING_KERNEL_BUILDDIR}"
543do_shared_workdir () {
544 cd ${B}
545
546 kerneldir=${STAGING_KERNEL_BUILDDIR}
547 install -d $kerneldir
548
549 #
550 # Store the kernel version in sysroots for module-base.bbclass
551 #
552
553 echo "${KERNEL_VERSION}" > $kerneldir/${KERNEL_PACKAGE_NAME}-abiversion
554
555 # Copy files required for module builds
556 cp System.map $kerneldir/System.map-${KERNEL_VERSION}
557 [ -e Module.symvers ] && cp Module.symvers $kerneldir/
558 cp .config $kerneldir/
559 mkdir -p $kerneldir/include/config
560 cp include/config/kernel.release $kerneldir/include/config/kernel.release
561 if [ -e certs/signing_key.x509 ]; then
562 # The signing_key.* files are stored in the certs/ dir in
563 # newer Linux kernels
564 mkdir -p $kerneldir/certs
565 cp certs/signing_key.* $kerneldir/certs/
566 elif [ -e signing_key.priv ]; then
567 cp signing_key.* $kerneldir/
568 fi
569
570 # We can also copy over all the generated files and avoid special cases
571 # like version.h, but we've opted to keep this small until file creep starts
572 # to happen
573 if [ -e include/linux/version.h ]; then
574 mkdir -p $kerneldir/include/linux
575 cp include/linux/version.h $kerneldir/include/linux/version.h
576 fi
577
578 # As of Linux kernel version 3.0.1, the clean target removes
579 # arch/powerpc/lib/crtsavres.o which is present in
580 # KBUILD_LDFLAGS_MODULE, making it required to build external modules.
581 if [ ${ARCH} = "powerpc" ]; then
582 if [ -e arch/powerpc/lib/crtsavres.o ]; then
583 mkdir -p $kerneldir/arch/powerpc/lib/
584 cp arch/powerpc/lib/crtsavres.o $kerneldir/arch/powerpc/lib/crtsavres.o
585 fi
586 fi
587
588 if [ -d include/generated ]; then
589 mkdir -p $kerneldir/include/generated/
590 cp -fR include/generated/* $kerneldir/include/generated/
591 fi
592
593 if [ -d arch/${ARCH}/include/generated ]; then
594 mkdir -p $kerneldir/arch/${ARCH}/include/generated/
595 cp -fR arch/${ARCH}/include/generated/* $kerneldir/arch/${ARCH}/include/generated/
596 fi
597
598 if (grep -q -i -e '^CONFIG_UNWINDER_ORC=y$' $kerneldir/.config); then
599 # With CONFIG_UNWINDER_ORC (the default in 4.14), objtool is required for
600 # out-of-tree modules to be able to generate object files.
601 if [ -x tools/objtool/objtool ]; then
602 mkdir -p ${kerneldir}/tools/objtool
603 cp tools/objtool/objtool ${kerneldir}/tools/objtool/
604 fi
605 fi
Patrick Williams7784c422022-11-17 07:29:11 -0600606
607 # When building with CONFIG_MODVERSIONS=y and CONFIG_RANDSTRUCT=y we need
608 # to copy the build assets generated for the randstruct seed to
609 # STAGING_KERNEL_BUILDDIR, otherwise the out-of-tree modules build will
610 # generate those assets which will result in a different
611 # RANDSTRUCT_HASHED_SEED
612 if [ -d scripts/basic ]; then
613 mkdir -p ${kerneldir}/scripts
614 cp -r scripts/basic ${kerneldir}/scripts
615 fi
616
617 if [ -d scripts/gcc-plugins ]; then
618 mkdir -p ${kerneldir}/scripts
619 cp -r scripts/gcc-plugins ${kerneldir}/scripts
620 fi
621
Patrick Williams92b42cb2022-09-03 06:53:57 -0500622}
623
624# We don't need to stage anything, not the modules/firmware since those would clash with linux-firmware
Patrick Williams2390b1b2022-11-03 13:47:49 -0500625SYSROOT_DIRS = ""
Patrick Williams92b42cb2022-09-03 06:53:57 -0500626
627KERNEL_CONFIG_COMMAND ?= "oe_runmake_call -C ${S} O=${B} olddefconfig || oe_runmake -C ${S} O=${B} oldnoconfig"
628
629python check_oldest_kernel() {
630 oldest_kernel = d.getVar('OLDEST_KERNEL')
631 kernel_version = d.getVar('KERNEL_VERSION')
632 tclibc = d.getVar('TCLIBC')
633 if tclibc == 'glibc':
634 kernel_version = kernel_version.split('-', 1)[0]
635 if oldest_kernel and kernel_version:
636 if bb.utils.vercmp_string(kernel_version, oldest_kernel) < 0:
637 bb.warn('%s: OLDEST_KERNEL is "%s" but the version of the kernel you are building is "%s" - therefore %s as built may not be compatible with this kernel. Either set OLDEST_KERNEL to an older version, or build a newer kernel.' % (d.getVar('PN'), oldest_kernel, kernel_version, tclibc))
638}
639
640check_oldest_kernel[vardepsexclude] += "OLDEST_KERNEL KERNEL_VERSION"
641do_configure[prefuncs] += "check_oldest_kernel"
642
643kernel_do_configure() {
644 # fixes extra + in /lib/modules/2.6.37+
645 # $ scripts/setlocalversion . => +
646 # $ make kernelversion => 2.6.37
647 # $ make kernelrelease => 2.6.37+
Andrew Geissler8f840682023-07-21 09:09:43 -0500648 # See kernel-arch.bbclass for post v6.3 removal of the extra
649 # + in localversion. .scmversion is no longer used, and the
650 # variable LOCALVERSION must be used
Patrick Williamsb542dec2023-06-09 01:26:37 -0500651 if [ ! -e ${B}/.scmversion -a ! -e ${S}/.scmversion ]; then
652 echo ${KERNEL_LOCALVERSION} > ${B}/.scmversion
653 echo ${KERNEL_LOCALVERSION} > ${S}/.scmversion
654 fi
Patrick Williams92b42cb2022-09-03 06:53:57 -0500655
656 if [ "${S}" != "${B}" ] && [ -f "${S}/.config" ] && [ ! -f "${B}/.config" ]; then
657 mv "${S}/.config" "${B}/.config"
658 fi
659
660 # Copy defconfig to .config if .config does not exist. This allows
661 # recipes to manage the .config themselves in do_configure:prepend().
662 if [ -f "${WORKDIR}/defconfig" ] && [ ! -f "${B}/.config" ]; then
663 cp "${WORKDIR}/defconfig" "${B}/.config"
664 fi
665
666 ${KERNEL_CONFIG_COMMAND}
667}
668
669do_savedefconfig() {
670 bbplain "Saving defconfig to:\n${B}/defconfig"
671 oe_runmake -C ${B} savedefconfig
672}
673do_savedefconfig[nostamp] = "1"
674addtask savedefconfig after do_configure
675
Andrew Geisslerfc113ea2023-03-31 09:59:46 -0500676inherit cml1 pkgconfig
Patrick Williams92b42cb2022-09-03 06:53:57 -0500677
678# Need LD, HOSTLDFLAGS and more for config operations
679KCONFIG_CONFIG_COMMAND:append = " ${EXTRA_OEMAKE}"
680
681EXPORT_FUNCTIONS do_compile do_transform_kernel do_transform_bundled_initramfs do_install do_configure
682
683# kernel-base becomes kernel-${KERNEL_VERSION}
684# kernel-image becomes kernel-image-${KERNEL_VERSION}
685PACKAGES = "${KERNEL_PACKAGE_NAME} ${KERNEL_PACKAGE_NAME}-base ${KERNEL_PACKAGE_NAME}-vmlinux ${KERNEL_PACKAGE_NAME}-image ${KERNEL_PACKAGE_NAME}-dev ${KERNEL_PACKAGE_NAME}-modules ${KERNEL_PACKAGE_NAME}-dbg"
686FILES:${PN} = ""
687FILES:${KERNEL_PACKAGE_NAME}-base = "${nonarch_base_libdir}/modules/${KERNEL_VERSION}/modules.order ${nonarch_base_libdir}/modules/${KERNEL_VERSION}/modules.builtin ${nonarch_base_libdir}/modules/${KERNEL_VERSION}/modules.builtin.modinfo"
688FILES:${KERNEL_PACKAGE_NAME}-image = ""
689FILES:${KERNEL_PACKAGE_NAME}-dev = "/${KERNEL_IMAGEDEST}/System.map* /${KERNEL_IMAGEDEST}/Module.symvers* /${KERNEL_IMAGEDEST}/config* ${KERNEL_SRC_PATH} ${nonarch_base_libdir}/modules/${KERNEL_VERSION}/build"
690FILES:${KERNEL_PACKAGE_NAME}-vmlinux = "/${KERNEL_IMAGEDEST}/vmlinux-${KERNEL_VERSION_NAME}"
691FILES:${KERNEL_PACKAGE_NAME}-modules = ""
692FILES:${KERNEL_PACKAGE_NAME}-dbg = "/usr/lib/debug /usr/src/debug"
693RDEPENDS:${KERNEL_PACKAGE_NAME} = "${KERNEL_PACKAGE_NAME}-base (= ${EXTENDPKGV})"
694# Allow machines to override this dependency if kernel image files are
695# not wanted in images as standard
696RRECOMMENDS:${KERNEL_PACKAGE_NAME}-base ?= "${KERNEL_PACKAGE_NAME}-image (= ${EXTENDPKGV})"
697PKG:${KERNEL_PACKAGE_NAME}-image = "${KERNEL_PACKAGE_NAME}-image-${@legitimize_package_name(d.getVar('KERNEL_VERSION'))}"
698RDEPENDS:${KERNEL_PACKAGE_NAME}-image += "${@oe.utils.conditional('KERNEL_IMAGETYPE', 'vmlinux', '${KERNEL_PACKAGE_NAME}-vmlinux (= ${EXTENDPKGV})', '', d)}"
699PKG:${KERNEL_PACKAGE_NAME}-base = "${KERNEL_PACKAGE_NAME}-${@legitimize_package_name(d.getVar('KERNEL_VERSION'))}"
700RPROVIDES:${KERNEL_PACKAGE_NAME}-base += "${KERNEL_PACKAGE_NAME}-${KERNEL_VERSION}"
701ALLOW_EMPTY:${KERNEL_PACKAGE_NAME} = "1"
702ALLOW_EMPTY:${KERNEL_PACKAGE_NAME}-base = "1"
703ALLOW_EMPTY:${KERNEL_PACKAGE_NAME}-image = "1"
704ALLOW_EMPTY:${KERNEL_PACKAGE_NAME}-modules = "1"
705DESCRIPTION:${KERNEL_PACKAGE_NAME}-modules = "Kernel modules meta package"
706
707pkg_postinst:${KERNEL_PACKAGE_NAME}-base () {
708 if [ ! -e "$D/lib/modules/${KERNEL_VERSION}" ]; then
709 mkdir -p $D/lib/modules/${KERNEL_VERSION}
710 fi
711 if [ -n "$D" ]; then
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500712 depmodwrapper -a -b $D ${KERNEL_VERSION} ${KERNEL_PACKAGE_NAME}
Patrick Williams92b42cb2022-09-03 06:53:57 -0500713 else
714 depmod -a ${KERNEL_VERSION}
715 fi
716}
717
Andrew Geissler517393d2023-01-13 08:55:19 -0600718PACKAGESPLITFUNCS =+ "split_kernel_packages"
Patrick Williams92b42cb2022-09-03 06:53:57 -0500719
720python split_kernel_packages () {
721 do_split_packages(d, root='${nonarch_base_libdir}/firmware', file_regex=r'^(.*)\.(bin|fw|cis|csp|dsp)$', output_pattern='${KERNEL_PACKAGE_NAME}-firmware-%s', description='Firmware for %s', recursive=True, extra_depends='')
722}
723
724# Many scripts want to look in arch/$arch/boot for the bootable
725# image. This poses a problem for vmlinux and vmlinuz based
726# booting. This task arranges to have vmlinux and vmlinuz appear
727# in the normalized directory location.
728do_kernel_link_images() {
729 if [ ! -d "${B}/arch/${ARCH}/boot" ]; then
730 mkdir ${B}/arch/${ARCH}/boot
731 fi
732 cd ${B}/arch/${ARCH}/boot
733 ln -sf ../../../vmlinux
734 if [ -f ../../../vmlinuz ]; then
735 ln -sf ../../../vmlinuz
736 fi
737 if [ -f ../../../vmlinuz.bin ]; then
738 ln -sf ../../../vmlinuz.bin
739 fi
740 if [ -f ../../../vmlinux.64 ]; then
741 ln -sf ../../../vmlinux.64
742 fi
743}
744addtask kernel_link_images after do_compile before do_strip
745
746python do_strip() {
747 import shutil
748
749 strip = d.getVar('STRIP')
750 extra_sections = d.getVar('KERNEL_IMAGE_STRIP_EXTRA_SECTIONS')
751 kernel_image = d.getVar('B') + "/" + d.getVar('KERNEL_OUTPUT_DIR') + "/vmlinux"
752
753 if (extra_sections and kernel_image.find(d.getVar('KERNEL_IMAGEDEST') + '/vmlinux') != -1):
754 kernel_image_stripped = kernel_image + ".stripped"
755 shutil.copy2(kernel_image, kernel_image_stripped)
756 oe.package.runstrip((kernel_image_stripped, 8, strip, extra_sections))
757 bb.debug(1, "KERNEL_IMAGE_STRIP_EXTRA_SECTIONS is set, stripping sections: " + \
758 extra_sections)
759}
760do_strip[dirs] = "${B}"
761
762addtask strip before do_sizecheck after do_kernel_link_images
763
764# Support checking the kernel size since some kernels need to reside in partitions
765# with a fixed length or there is a limit in transferring the kernel to memory.
766# If more than one image type is enabled, warn on any that don't fit but only fail
767# if none fit.
768do_sizecheck() {
769 if [ ! -z "${KERNEL_IMAGE_MAXSIZE}" ]; then
770 invalid=`echo ${KERNEL_IMAGE_MAXSIZE} | sed 's/[0-9]//g'`
771 if [ -n "$invalid" ]; then
772 die "Invalid KERNEL_IMAGE_MAXSIZE: ${KERNEL_IMAGE_MAXSIZE}, should be an integer (The unit is Kbytes)"
773 fi
774 at_least_one_fits=
775 for imageType in ${KERNEL_IMAGETYPES} ; do
776 size=`du -ks ${B}/${KERNEL_OUTPUT_DIR}/$imageType | awk '{print $1}'`
777 if [ $size -gt ${KERNEL_IMAGE_MAXSIZE} ]; then
778 bbwarn "This kernel $imageType (size=$size(K) > ${KERNEL_IMAGE_MAXSIZE}(K)) is too big for your device."
779 else
780 at_least_one_fits=y
781 fi
782 done
783 if [ -z "$at_least_one_fits" ]; then
784 die "All kernel images are too big for your device. Please reduce the size of the kernel by making more of it modular."
785 fi
786 fi
787}
788do_sizecheck[dirs] = "${B}"
789
790addtask sizecheck before do_install after do_strip
791
792inherit kernel-artifact-names
793
794kernel_do_deploy() {
795 deployDir="${DEPLOYDIR}"
796 if [ -n "${KERNEL_DEPLOYSUBDIR}" ]; then
797 deployDir="${DEPLOYDIR}/${KERNEL_DEPLOYSUBDIR}"
798 mkdir "$deployDir"
799 fi
800
801 for imageType in ${KERNEL_IMAGETYPES} ; do
802 baseName=$imageType-${KERNEL_IMAGE_NAME}
803
804 if [ -s ${KERNEL_OUTPUT_DIR}/$imageType.stripped ] ; then
805 install -m 0644 ${KERNEL_OUTPUT_DIR}/$imageType.stripped $deployDir/$baseName${KERNEL_IMAGE_BIN_EXT}
806 else
807 install -m 0644 ${KERNEL_OUTPUT_DIR}/$imageType $deployDir/$baseName${KERNEL_IMAGE_BIN_EXT}
808 fi
809 if [ -n "${KERNEL_IMAGE_LINK_NAME}" ] ; then
810 ln -sf $baseName${KERNEL_IMAGE_BIN_EXT} $deployDir/$imageType-${KERNEL_IMAGE_LINK_NAME}${KERNEL_IMAGE_BIN_EXT}
811 fi
812 if [ "${KERNEL_IMAGETYPE_SYMLINK}" = "1" ] ; then
813 ln -sf $baseName${KERNEL_IMAGE_BIN_EXT} $deployDir/$imageType
814 fi
815 done
816
817 if [ ${MODULE_TARBALL_DEPLOY} = "1" ] && (grep -q -i -e '^CONFIG_MODULES=y$' .config); then
818 mkdir -p ${D}${root_prefix}/lib
819 if [ -n "${SOURCE_DATE_EPOCH}" ]; then
820 TAR_ARGS="--sort=name --clamp-mtime --mtime=@${SOURCE_DATE_EPOCH}"
821 else
822 TAR_ARGS=""
823 fi
824 TAR_ARGS="$TAR_ARGS --owner=0 --group=0"
825 tar $TAR_ARGS -cv -C ${D}${root_prefix} lib | gzip -9n > $deployDir/modules-${MODULE_TARBALL_NAME}.tgz
826
827 if [ -n "${MODULE_TARBALL_LINK_NAME}" ] ; then
828 ln -sf modules-${MODULE_TARBALL_NAME}.tgz $deployDir/modules-${MODULE_TARBALL_LINK_NAME}.tgz
829 fi
830 fi
831
832 if [ ! -z "${INITRAMFS_IMAGE}" -a x"${INITRAMFS_IMAGE_BUNDLE}" = x1 ]; then
833 for imageType in ${KERNEL_IMAGETYPES} ; do
834 if [ "$imageType" = "fitImage" ] ; then
835 continue
836 fi
837 initramfsBaseName=$imageType-${INITRAMFS_NAME}
838 install -m 0644 ${KERNEL_OUTPUT_DIR}/$imageType.initramfs $deployDir/$initramfsBaseName${KERNEL_IMAGE_BIN_EXT}
839 if [ -n "${INITRAMFS_LINK_NAME}" ] ; then
840 ln -sf $initramfsBaseName${KERNEL_IMAGE_BIN_EXT} $deployDir/$imageType-${INITRAMFS_LINK_NAME}${KERNEL_IMAGE_BIN_EXT}
841 fi
842 done
843 fi
844}
845
846# We deploy to filenames that include PKGV and PKGR, read the saved data to
847# ensure we get the right values for both
848do_deploy[prefuncs] += "read_subpackage_metadata"
849
850addtask deploy after do_populate_sysroot do_packagedata
851
852EXPORT_FUNCTIONS do_deploy
853
854# Add using Device Tree support
855inherit kernel-devicetree