blob: fdbdfb6502f6a81c9618db9c808d43041a5f0ea2 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter"
2DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \
3a back-end to a program such as ghostview, it can display PostScript and PDF \
4documents in an X11 environment. \
5\
6Furthermore, it can render PostScript and PDF files as graphics to be printed \
7on non-PostScript printers. Supported printers include common \
8dot-matrix, inkjet and laser models. \
9"
10HOMEPAGE = "http://www.ghostscript.com"
11SECTION = "console/utils"
12
13LICENSE = "GPL-3.0-only"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=f98ffa763e50cded76f49bce73aade16"
15
Patrick Williams520786c2023-06-25 16:20:36 -050016DEPENDS = "tiff jpeg fontconfig cups libpng freetype zlib"
Andrew Geissler517393d2023-01-13 08:55:19 -060017
18UPSTREAM_CHECK_URI = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases"
19UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
20
Andrew Geissler517393d2023-01-13 08:55:19 -060021def gs_verdir(v):
22 return "".join(v.split("."))
23
24
Patrick Williams520786c2023-06-25 16:20:36 -050025SRC_URI = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${@gs_verdir("${PV}")}/${BPN}-${PV}.tar.gz \
26 file://ghostscript-9.16-Werror-return-type.patch \
27 file://avoid-host-contamination.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060028"
29
Andrew Geissler8f840682023-07-21 09:09:43 -050030SRC_URI[sha256sum] = "a4cd61a07fec161bee35da0211a5e5cde8ff8a0aaf942fc0176715e499d21661"
Andrew Geissler517393d2023-01-13 08:55:19 -060031
Patrick Williams520786c2023-06-25 16:20:36 -050032PACKAGECONFIG ??= ""
33PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+3"
34PACKAGECONFIG[libidn] = "--with-libidn,--without-libidn,libidn"
35PACKAGECONFIG[libpaper] = "--with-libpaper,--without-libpaper,libpaper"
Andrew Geissler517393d2023-01-13 08:55:19 -060036PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}, \
Patrick Williams520786c2023-06-25 16:20:36 -050037 --without-x, virtual/libx11 libxext libxt"
Andrew Geissler517393d2023-01-13 08:55:19 -060038
Patrick Williams520786c2023-06-25 16:20:36 -050039EXTRA_OECONF = "--with-jbig2dec \
Andrew Geissler517393d2023-01-13 08:55:19 -060040 --with-fontpath=${datadir}/fonts \
Andrew Geissler517393d2023-01-13 08:55:19 -060041 CUPSCONFIG="${STAGING_BINDIR_CROSS}/cups-config" \
Patrick Williams520786c2023-06-25 16:20:36 -050042 PKGCONFIG=pkg-config \
Andrew Geissler517393d2023-01-13 08:55:19 -060043 "
44
45EXTRA_OECONF:append:mipsarcho32 = " --with-large_color_index=0"
46
Patrick Williams520786c2023-06-25 16:20:36 -050047# Uses autoconf but not automake, can't do out-of-tree
48inherit autotools-brokensep pkgconfig
Andrew Geissler517393d2023-01-13 08:55:19 -060049
Patrick Williams520786c2023-06-25 16:20:36 -050050# Prune the source tree of libraries that we're using our packaging of, so that
51# ghostscript can't link to them. Can't prune zlib as that's needed for the
52# native tools.
53prune_sources() {
54 rm -rf ${S}/jpeg/ ${S}/libpng/ ${S}/tiff/ ${S}/expat/ ${S}/freetype/ ${S}/cups/lib
Andrew Geissler517393d2023-01-13 08:55:19 -060055}
Patrick Williams520786c2023-06-25 16:20:36 -050056do_unpack[postfuncs] += "prune_sources"
Andrew Geissler517393d2023-01-13 08:55:19 -060057
58do_install:append () {
59 mkdir -p ${D}${datadir}/ghostscript/${PV}/
60 cp -r ${S}/Resource ${D}${datadir}/ghostscript/${PV}/
61 cp -r ${S}/iccprofiles ${D}${datadir}/ghostscript/${PV}/
62}
63
Andrew Geissler517393d2023-01-13 08:55:19 -060064# ghostscript does not supports "arc"
65COMPATIBLE_HOST = "^(?!arc).*"
66
67# some entries in NVD uses gpl_ghostscript
68CVE_PRODUCT = "ghostscript gpl_ghostscript"