blob: edd7ad38fd6c7e27730beec468fa75c9c9c0f2cf [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Library for rendering SVG files"
2DESCRIPTION = "A small library to render Scalable Vector Graphics (SVG), \
3associated with the GNOME Project. It renders SVG files to Cairo surfaces. \
4Cairo is the 2D, antialiased drawing library that GNOME uses to draw things to \
5the screen or to generate output for printing."
6HOMEPAGE = "https://gitlab.gnome.org/GNOME/librsvg"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/librsvg/issues"
8
9LICENSE = "LGPL-2.1-or-later"
10LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
11 "
12
13SECTION = "x11/utils"
14DEPENDS = "cairo gdk-pixbuf glib-2.0 libxml2 pango python3-docutils-native"
15BBCLASSEXTEND = "native nativesdk"
16
Patrick Williamse760df82023-05-26 11:10:49 -050017inherit cargo_common gnomebase pixbufcache upstream-version-is-even gobject-introspection rust vala gi-docgen cargo-update-recipe-crates
18
19require ${BPN}-crates.inc
Patrick Williams92b42cb2022-09-03 06:53:57 -050020
21SRC_URI += "file://0001-Makefile.am-pass-rust-target-to-cargo-also-when-not-.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050022 "
23
Andrew Geissler8f840682023-07-21 09:09:43 -050024SRC_URI[archive.sha256sum] = "1685aeacae9a441dcb12c0c3ec63706172a2f52705dafbefb8e7311d4d5e430b"
Patrick Williams92b42cb2022-09-03 06:53:57 -050025
26# librsvg is still autotools-based, but is calling cargo from its automake-driven makefiles
27# so we cannot use cargo class directly, but still need bits and pieces from it
28# for cargo to be happy
29BASEDEPENDS:append = " cargo-native"
30
31export RUST_BACKTRACE = "full"
32export RUSTFLAGS
33
34export RUST_TARGET = "${RUST_HOST_SYS}"
35
36RUSTFLAGS:append:mips = " --cfg crossbeam_no_atomic_64"
37RUSTFLAGS:append:mipsel = " --cfg crossbeam_no_atomic_64"
38RUSTFLAGS:append:powerpc = " --cfg crossbeam_no_atomic_64"
39RUSTFLAGS:append:riscv32 = " --cfg crossbeam_no_atomic_64"
40
Patrick Williams92b42cb2022-09-03 06:53:57 -050041do_configure[postfuncs] += "cargo_common_do_configure"
42
43inherit rust-target-config
44
Patrick Williams92b42cb2022-09-03 06:53:57 -050045# rust-cross writes the target linker binary into target json definition without any flags.
46# This breaks here because the linker isn't going to work without at least knowing where
47# the sysroot is. So copy the json to workdir, and patch in the path to wrapper from rust class
48# which supplies the needed flags.
49do_compile:prepend() {
50 sed -ie 's,"linker": ".*","linker": "${RUST_TARGET_CC}",g' ${RUST_TARGETS_DIR}/${RUST_HOST_SYS}.json
51}
52
Andrew Geissler8f840682023-07-21 09:09:43 -050053CVE_STATUS[CVE-2018-1000041] = "not-applicable-platform: Issue only applies on Windows"
Patrick Williams92b42cb2022-09-03 06:53:57 -050054
55CACHED_CONFIGUREVARS = "ac_cv_path_GDK_PIXBUF_QUERYLOADERS=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders"
56
57PACKAGECONFIG ??= "gdkpixbuf"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060058PACKAGECONFIG:append:class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'vala', '', d)}"
Patrick Williams92b42cb2022-09-03 06:53:57 -050059# The gdk-pixbuf loader
60PACKAGECONFIG[gdkpixbuf] = "--enable-pixbuf-loader,--disable-pixbuf-loader,gdk-pixbuf-native"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060061PACKAGECONFIG[vala] = "--enable-vala,--disable-vala"
Patrick Williams92b42cb2022-09-03 06:53:57 -050062
63do_install:append() {
64 # Loadable modules don't need .a or .la on Linux
65 rm -f ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.a ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.la
66}
67
68PACKAGES =+ "librsvg-gtk rsvg"
69FILES:rsvg = "${bindir}/rsvg* \
70 ${datadir}/pixmaps/svg-viewer.svg \
71 ${datadir}/themes"
72FILES:librsvg-gtk = "${libdir}/gdk-pixbuf-2.0/*/*/*.so \
73 ${datadir}/thumbnailers/librsvg.thumbnailer"
74RRECOMMENDS:librsvg-gtk = "gdk-pixbuf-bin"
75
76PIXBUF_PACKAGES = "librsvg-gtk"