Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | require gstreamer1.0-plugins-common.inc |
| 2 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 3 | SUMMARY = "'Base' GStreamer plugins and helper libraries" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 4 | HOMEPAGE = "https://gstreamer.freedesktop.org/" |
| 5 | BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/issues" |
| 6 | LICENSE = "LGPL-2.1-or-later" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=69333daa044cb77e486cc36129f7a770" |
| 8 | |
| 9 | SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \ |
| 10 | file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \ |
| 11 | file://0003-viv-fb-Make-sure-config.h-is-included.patch \ |
| 12 | file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \ |
| 13 | " |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame^] | 14 | SRC_URI[sha256sum] = "292424e82dea170528c42b456f62a89532bcabc0508f192e34672fb86f68e5b8" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/gst-plugins-base-${PV}" |
| 17 | |
| 18 | DEPENDS += "iso-codes util-linux zlib" |
| 19 | |
| 20 | inherit gobject-introspection |
| 21 | |
| 22 | # opengl packageconfig factored out to make it easy for distros |
| 23 | # and BSP layers to choose OpenGL APIs/platforms/window systems |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame^] | 24 | PACKAGECONFIG_X11 = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'opengl glx', '', d)}" |
| 25 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl ${PACKAGECONFIG_X11}', '', d)}" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 26 | |
| 27 | PACKAGECONFIG ??= " \ |
| 28 | ${GSTREAMER_ORC} \ |
| 29 | ${PACKAGECONFIG_GL} \ |
| 30 | ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \ |
| 31 | jpeg ogg pango png theora vorbis \ |
| 32 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \ |
| 33 | " |
| 34 | |
| 35 | OPENGL_APIS = 'opengl gles2' |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame^] | 36 | OPENGL_PLATFORMS = 'egl glx' |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 37 | |
| 38 | X11DEPENDS = "virtual/libx11 libsm libxrender libxv" |
| 39 | X11ENABLEOPTS = "-Dx11=enabled -Dxvideo=enabled -Dxshm=enabled" |
| 40 | X11DISABLEOPTS = "-Dx11=disabled -Dxvideo=disabled -Dxshm=disabled" |
| 41 | |
| 42 | PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib" |
| 43 | PACKAGECONFIG[cdparanoia] = "-Dcdparanoia=enabled,-Dcdparanoia=disabled,cdparanoia" |
| 44 | PACKAGECONFIG[graphene] = "-Dgl-graphene=enabled,-Dgl-graphene=disabled,graphene" |
| 45 | PACKAGECONFIG[jpeg] = "-Dgl-jpeg=enabled,-Dgl-jpeg=disabled,jpeg" |
| 46 | PACKAGECONFIG[ogg] = "-Dogg=enabled,-Dogg=disabled,libogg" |
| 47 | PACKAGECONFIG[opus] = "-Dopus=enabled,-Dopus=disabled,libopus" |
| 48 | PACKAGECONFIG[pango] = "-Dpango=enabled,-Dpango=disabled,pango" |
| 49 | PACKAGECONFIG[png] = "-Dgl-png=enabled,-Dgl-png=disabled,libpng" |
| 50 | # This enables Qt5 QML examples in -base. The Qt5 GStreamer |
| 51 | # qmlglsink and qmlglsrc plugins still exist in -good. |
| 52 | PACKAGECONFIG[qt5] = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native" |
| 53 | PACKAGECONFIG[theora] = "-Dtheora=enabled,-Dtheora=disabled,libtheora" |
| 54 | PACKAGECONFIG[tremor] = "-Dtremor=enabled,-Dtremor=disabled,tremor" |
| 55 | PACKAGECONFIG[visual] = "-Dlibvisual=enabled,-Dlibvisual=disabled,libvisual" |
| 56 | PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis" |
| 57 | PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}" |
| 58 | |
| 59 | # OpenGL API packageconfigs |
| 60 | PACKAGECONFIG[opengl] = ",,virtual/libgl libglu" |
| 61 | PACKAGECONFIG[gles2] = ",,virtual/libgles2" |
| 62 | |
| 63 | # OpenGL platform packageconfigs |
| 64 | PACKAGECONFIG[egl] = ",,virtual/egl" |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame^] | 65 | PACKAGECONFIG[glx] = ",,virtual/libgl" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 66 | |
| 67 | # OpenGL window systems (except for X11) |
| 68 | PACKAGECONFIG[gbm] = ",,virtual/libgbm libgudev libdrm" |
| 69 | PACKAGECONFIG[wayland] = ",,wayland-native wayland wayland-protocols libdrm" |
| 70 | PACKAGECONFIG[dispmanx] = ",,virtual/libomxil" |
| 71 | PACKAGECONFIG[viv-fb] = ",,virtual/libgles2 virtual/libg2d" |
| 72 | |
| 73 | OPENGL_WINSYS = "${@bb.utils.filter('PACKAGECONFIG', 'x11 gbm wayland dispmanx egl viv-fb', d)}" |
| 74 | |
| 75 | EXTRA_OEMESON += " \ |
| 76 | -Ddoc=disabled \ |
| 77 | ${@get_opengl_cmdline_list('gl_api', d.getVar('OPENGL_APIS'), d)} \ |
| 78 | ${@get_opengl_cmdline_list('gl_platform', d.getVar('OPENGL_PLATFORMS'), d)} \ |
| 79 | ${@get_opengl_cmdline_list('gl_winsys', d.getVar('OPENGL_WINSYS'), d)} \ |
| 80 | " |
| 81 | |
| 82 | FILES:${PN}-dev += "${libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h" |
| 83 | FILES:${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict" |
| 84 | |
| 85 | def get_opengl_cmdline_list(switch_name, options, d): |
| 86 | selected_options = [] |
| 87 | if bb.utils.contains('DISTRO_FEATURES', 'opengl', True, False, d): |
| 88 | for option in options.split(): |
| 89 | if bb.utils.contains('PACKAGECONFIG', option, True, False, d): |
| 90 | selected_options += [option] |
| 91 | if selected_options: |
| 92 | return '-D' + switch_name + '=' + ','.join(selected_options) |
| 93 | else: |
| 94 | return '' |
| 95 | |
| 96 | CVE_PRODUCT += "gst-plugins-base" |