blob: 8bef0b160559d8c06b1aedcc44f15dbc8388d3b1 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "https://www.webkitgtk.org/"
3BUGTRACKER = "https://bugs.webkit.org/"
4
5LICENSE = "BSD-2-Clause & LGPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://reproducibility.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060015 file://0d3344e17d258106617b0e6d783d073b188a2548.patch \
Andrew Geissler8f840682023-07-21 09:09:43 -050016 file://4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch \
17 file://0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch \
18 file://check-GST_GL_HAVE_PLATFORM_GLX.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060019 "
Andrew Geissler8f840682023-07-21 09:09:43 -050020SRC_URI[sha256sum] = "96898870d994da406ee7a632816dcde9a3bb395ee5f344fcb3f3b8cc8a77e000"
Andrew Geissler517393d2023-01-13 08:55:19 -060021
22inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gi-docgen
23
24ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
25REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}"
26
27CVE_PRODUCT = "webkitgtk webkitgtk\+"
28
Andrew Geisslerc5535c92023-01-27 16:10:19 -060029DEPENDS += " \
Andrew Geissler517393d2023-01-13 08:55:19 -060030 ruby-native \
31 gperf-native \
Andrew Geissler8f840682023-07-21 09:09:43 -050032 unifdef-native \
Andrew Geissler517393d2023-01-13 08:55:19 -060033 cairo \
34 harfbuzz \
35 jpeg \
36 atk \
37 libwebp \
38 gtk+3 \
39 libxslt \
40 libtasn1 \
41 libnotify \
42 gstreamer1.0 \
43 gstreamer1.0-plugins-base \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050044 glib-2.0-native \
45 gettext-native \
Andrew Geissler517393d2023-01-13 08:55:19 -060046 "
47
48PACKAGECONFIG_SOUP ?= "soup3"
49PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
50 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \
51 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2', d)} \
52 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl-or-es', '', d)} \
53 enchant \
54 libsecret \
55 ${PACKAGECONFIG_SOUP} \
56 "
57
58PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native"
59PACKAGECONFIG[angle] = "-DUSE_ANGLE_WEBGL=ON,-DUSE_ANGLE_WEBGL=OFF"
60PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt"
61PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
62PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2"
63PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
64PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/egl"
65PACKAGECONFIG[opengl] = "-DENABLE_GRAPHICS_CONTEXT_GL=ON,-DENABLE_GRAPHICS_CONTEXT_GL=OFF,virtual/egl"
66PACKAGECONFIG[opengl-or-es] = "-DUSE_OPENGL_OR_ES=ON,-DUSE_OPENGL_OR_ES=OFF"
67PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
68PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
69PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"
70PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
71PACKAGECONFIG[systemd] = "-DUSE_SYSTEMD=ON,-DUSE_SYSTEMD=off,systemd"
72PACKAGECONFIG[reduce-size] = "-DCMAKE_BUILD_TYPE=MinSizeRel,-DCMAKE_BUILD_TYPE=Release,,"
73PACKAGECONFIG[lcms] = "-DUSE_LCMS=ON,-DUSE_LCMS=OFF,lcms"
74PACKAGECONFIG[soup2] = "-DUSE_SOUP2=ON,-DUSE_SOUP2=OFF,libsoup-2.4,,,soup3"
75PACKAGECONFIG[soup3] = ",,libsoup,,,soup2"
76PACKAGECONFIG[journald] = "-DENABLE_JOURNALD_LOG=ON,-DENABLE_JOURNALD_LOG=OFF,systemd"
Andrew Geissler8f840682023-07-21 09:09:43 -050077PACKAGECONFIG[avif] = "-DUSE_AVIF_LOG=ON,-DUSE_AVIF=OFF,libavif"
78PACKAGECONFIG[media-recorder] = "-DENABLE_MEDIA_RECORDER=ON,-DENABLE_MEDIA_RECORDER=OFF,gstreamer1.0-plugins-bad"
Andrew Geissler517393d2023-01-13 08:55:19 -060079
Andrew Geissler517393d2023-01-13 08:55:19 -060080EXTRA_OECMAKE = " \
81 -DPORT=GTK \
82 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
83 ${@bb.utils.contains('GIDOCGEN_ENABLED', 'True', '-DENABLE_DOCUMENTATION=ON', '-DENABLE_DOCUMENTATION=OFF', d)} \
84 -DENABLE_MINIBROWSER=ON \
Andrew Geissler517393d2023-01-13 08:55:19 -060085 -DENABLE_BUBBLEWRAP_SANDBOX=OFF \
86 -DENABLE_GAMEPAD=OFF \
87 "
88
89# Javascript JIT is not supported on ARC
90EXTRA_OECMAKE:append:arc = " -DENABLE_JIT=OFF "
91# By default 25-bit "medium" calls are used on ARC
92# which is not enough for binaries larger than 32 MiB
93CFLAGS:append:arc = " -mlong-calls"
94CXXFLAGS:append:arc = " -mlong-calls"
95
96# Needed for non-mesa graphics stacks when x11 is disabled
97CXXFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}"
98
99# Javascript JIT is not supported on powerpc
100EXTRA_OECMAKE:append:powerpc = " -DENABLE_JIT=OFF "
101EXTRA_OECMAKE:append:powerpc64 = " -DENABLE_JIT=OFF "
102
103# ARM JIT code does not build on ARMv4/5/6 anymore
104EXTRA_OECMAKE:append:armv5 = " -DENABLE_JIT=OFF "
105EXTRA_OECMAKE:append:armv6 = " -DENABLE_JIT=OFF "
106EXTRA_OECMAKE:append:armv4 = " -DENABLE_JIT=OFF "
107
108EXTRA_OECMAKE:append:mipsarch = " -DUSE_LD_GOLD=OFF "
109EXTRA_OECMAKE:append:powerpc = " -DUSE_LD_GOLD=OFF "
110
111# JIT and gold linker does not work on RISCV
112EXTRA_OECMAKE:append:riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
Andrew Geissler8f840682023-07-21 09:09:43 -0500113EXTRA_OECMAKE:append:riscv64 = " -DUSE_LD_GOLD=OFF"
Andrew Geissler517393d2023-01-13 08:55:19 -0600114
115# JIT not supported on MIPS either
116EXTRA_OECMAKE:append:mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
117
118# JIT not supported on X32
119# An attempt was made to upstream JIT support for x32 in
120# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
121# unresolved due to limited X32 adoption.
122EXTRA_OECMAKE:append:x86-x32 = " -DENABLE_JIT=OFF "
123
124SECURITY_CFLAGS:remove:aarch64 = "-fpie"
125SECURITY_CFLAGS:append:aarch64 = " -fPIE"
126
127FILES:${PN} += "${libdir}/webkit2gtk-4.*/injected-bundle/libwebkit2gtkinjectedbundle.so"
128
129RRECOMMENDS:${PN} += "ca-certificates shared-mime-info"
130
131# http://errors.yoctoproject.org/Errors/Details/20370/
132ARM_INSTRUCTION_SET:armv4 = "arm"
133ARM_INSTRUCTION_SET:armv5 = "arm"
134ARM_INSTRUCTION_SET:armv6 = "arm"
135
136# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
137# https://bugs.webkit.org/show_bug.cgi?id=159880
138# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
139# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
140ARM_INSTRUCTION_SET:armv7a = "thumb"
141ARM_INSTRUCTION_SET:armv7r = "thumb"
142ARM_INSTRUCTION_SET:armv7ve = "thumb"
143
Andrew Geissler8f840682023-07-21 09:09:43 -0500144# ANGLE requires SSE support as of webkit 2.40.x on 32 bit x86
145COMPATIBLE_HOST:x86 = "${@bb.utils.contains_any('TUNE_FEATURES', 'core2 corei7', '.*', 'null', d)}"
146
Andrew Geissler517393d2023-01-13 08:55:19 -0600147# introspection inside qemu-arm hangs forever on musl/arm builds
148# therefore disable GI_DATA
149GI_DATA_ENABLED:libc-musl:armv7a = "False"
150GI_DATA_ENABLED:libc-musl:armv7ve = "False"
151
152# Can't be built with ccache
153CCACHE_DISABLE = "1"
154
155PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
156src_package_preprocess () {
157 # Trim build paths from comments in generated sources to ensure reproducibility
158 sed -i -e "s,${WORKDIR},,g" \
159 ${B}/JavaScriptCore/DerivedSources/*.h \
160 ${B}/JavaScriptCore/DerivedSources/yarr/*.h \
161 ${B}/JavaScriptCore/PrivateHeaders/JavaScriptCore/*.h \
Andrew Geissler8f840682023-07-21 09:09:43 -0500162 ${B}/WebCore/DerivedSources/*.cpp \
163 ${B}/WebKitGTK/DerivedSources/webkit/*.cpp
Andrew Geissler517393d2023-01-13 08:55:19 -0600164
165}
166