Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "The dump DAQ test the various inline mode features " |
| 2 | HOMEPAGE = "http://www.snort.org" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=f9ce51a65dd738dc1ae631d8b21c40e0" |
| 6 | |
| 7 | PARALLEL_MAKE = "" |
| 8 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 9 | DEPENDS = "libpcap libpcre libdnet bison-native" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 10 | |
| 11 | SRC_URI = "http://fossies.org/linux/misc/daq-${PV}.tar.gz \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | file://disable-run-test-program-while-cross-compiling.patch \ |
| 13 | file://0001-correct-the-location-of-unistd.h.patch \ |
| 14 | " |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "bdc4e5a24d1ea492c39ee213a63c55466a2e8114b6a9abed609927ae13a7705e" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 16 | # these 2 create undeclared dependency on libdnet and libnetfilter-queue from meta-networking |
| 17 | # this error from test-dependencies script: |
| 18 | # daq/daq/latest lost dependency on libdnet libmnl libnetfilter-queue libnfnetlink |
| 19 | # |
| 20 | # never look to /usr/local lib while cross compiling |
| 21 | |
| 22 | EXTRA_OECONF = "--disable-nfq-module --disable-ipq-module --includedir=${includedir} \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 23 | --with-libpcap-includes=${STAGING_INCDIR} --with-dnet-includes=${STAGING_LIBDIR}" |
| 24 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 25 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 26 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 27 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 28 | inherit autotools |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 29 | |
| 30 | DISABLE_STATIC = "" |
| 31 | |
| 32 | BBCLASSEXTEND = "native" |