Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "PolicyKit Authorization Framework" |
| 2 | DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes." |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/polkit" |
| 4 | LICENSE = "LGPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \ |
| 6 | file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4" |
| 7 | |
| 8 | DEPENDS = "expat glib-2.0 intltool-native mozjs" |
| 9 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 10 | inherit autotools gtk-doc pkgconfig useradd systemd gobject-introspection features_check |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | |
| 12 | REQUIRED_DISTRO_FEATURES = "polkit" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | |
| 14 | PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \ |
| 15 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', \ |
| 16 | bb.utils.contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d), d)} \ |
| 17 | " |
| 18 | |
| 19 | PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam" |
| 20 | PACKAGECONFIG[systemd] = "--enable-libsystemd-login=yes --with-systemdsystemunitdir=${systemd_unitdir}/system/,--enable-libsystemd-login=no --with-systemdsystemunitdir=,systemd" |
| 21 | # there is no --enable/--disable option for consolekit and it's not picked by shlibs, so add it to RDEPENDS |
| 22 | PACKAGECONFIG[consolekit] = ",,,consolekit" |
| 23 | |
| 24 | PAM_SRC_URI = "file://polkit-1_pam.patch" |
| 25 | SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 26 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \ |
| 27 | file://0003-make-netgroup-support-optional.patch \ |
| 28 | " |
| 29 | SRC_URI[md5sum] = "4b37258583393e83069a0e2e89c0162a" |
| 30 | SRC_URI[sha256sum] = "88170c9e711e8db305a12fdb8234fac5706c61969b94e084d0f117d8ec5d34b1" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | |
| 32 | EXTRA_OECONF = "--with-os-type=moblin \ |
| 33 | --disable-man-pages \ |
| 34 | --disable-libelogind \ |
| 35 | " |
| 36 | |
| 37 | do_compile_prepend () { |
| 38 | export GIR_EXTRA_LIBS_PATH="${B}/src/polkit/.libs" |
| 39 | } |
| 40 | |
| 41 | PACKAGES =+ "${PN}-examples" |
| 42 | |
| 43 | FILES_${PN}_append = " \ |
| 44 | ${libdir}/${BPN}-1 \ |
| 45 | ${nonarch_libdir}/${BPN}-1 \ |
| 46 | ${datadir}/dbus-1 \ |
| 47 | ${datadir}/${BPN}-1 \ |
| 48 | ${datadir}/gettext \ |
| 49 | " |
| 50 | |
| 51 | FILES_${PN}-examples = "${bindir}/*example*" |
| 52 | |
| 53 | USERADD_PACKAGES = "${PN}" |
| 54 | USERADD_PARAM_${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd" |
| 55 | |
| 56 | SYSTEMD_SERVICE_${PN} = "${BPN}.service" |
| 57 | SYSTEMD_AUTO_ENABLE = "disable" |