Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 1 | SUMMARY = "Extensions to the standard Python datetime module" |
| 2 | DESCRIPTION = "The dateutil module provides powerful extensions to the datetime module available in the Python standard library." |
| 3 | HOMEPAGE = "https://dateutil.readthedocs.org" |
| 4 | LICENSE = "BSD-3-Clause & Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3155c7bdc71f66e02678411d2abf996" |
| 6 | |
| 7 | SRC_URI[md5sum] = "f2a1d4b680b297b367a974664ca3a4f6" |
| 8 | SRC_URI[sha256sum] = "73ebfe9dbf22e832286dafa60473e4cd239f8592f699aa5adaf10050e6e1823c" |
| 9 | |
| 10 | PYPI_PACKAGE = "python-dateutil" |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | PACKAGES =+ "${PN}-zoneinfo" |
| 14 | FILES_${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo" |
| 15 | |
| 16 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" |
| 17 | |
| 18 | RDEPENDS_${PN} = "\ |
| 19 | ${PYTHON_PN}-datetime \ |
| 20 | ${PYTHON_PN}-numbers \ |
| 21 | ${PYTHON_PN}-six \ |
| 22 | ${PYTHON_PN}-stringold \ |
| 23 | " |
| 24 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 25 | BBCLASSEXTEND = "native nativesdk" |