Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "et_xmlfile is a low memory library for creating large XML files" |
| 2 | DESCRIPTION = "It is based upon the xmlfile module from lxml with the aim of allowing code \ |
| 3 | to be developed that will work with both libraries. It was developed initially for \ |
| 4 | the openpyxl project but is now a standalone module." |
| 5 | |
| 6 | HOMEPAGE = "https://bitbucket.org/openpyxl/et_xmlfile/src/default/" |
| 7 | LICENSE = "MIT" |
| 8 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=b3d89cae66f26c3a0799be8a96f3178b" |
| 9 | |
| 10 | SRC_URI[md5sum] = "f47940fd9d556375420b2e276476cfaf" |
| 11 | SRC_URI[sha256sum] = "614d9722d572f6246302c4491846d2c393c199cfa4edc9af593437691683335b" |
| 12 | |
| 13 | RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell" |
| 14 | |
| 15 | inherit setuptools3 |
| 16 | PYPI_PACKAGE ?= "et_xmlfile" |
| 17 | PYPI_SRC_URI ?= "https://files.pythonhosted.org/packages/source/e/et_xmlfile/et_xmlfile-1.0.1.tar.gz" |
| 18 | SECTION = "devel/python" |
| 19 | SRC_URI += "${PYPI_SRC_URI}" |
| 20 | S = "${WORKDIR}/${PYPI_PACKAGE}-${PV}" |