Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Python bindings and utilities for GeoJSON" |
| 2 | HOMEPAGE = "https://pypi.org/project/geojson/" |
| 3 | LICENSE = "BSD" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=f48972abe5cddee79e301574742ed745" |
| 5 | |
| 6 | SRC_URI[md5sum] = "14753ed28678828b1de73f68b04e2324" |
| 7 | SRC_URI[sha256sum] = "6e4bb7ace4226a45d9c8c8b1348b3fc43540658359f93c3f7e03efa9f15f658a" |
| 8 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 9 | inherit pypi setuptools3 ptest |
| 10 | |
| 11 | SRC_URI += " \ |
| 12 | file://run-ptest \ |
| 13 | " |
| 14 | |
| 15 | RDEPENDS_${PN}-ptest += " \ |
| 16 | ${PYTHON_PN}-pytest \ |
| 17 | " |
| 18 | |
| 19 | do_install_ptest() { |
| 20 | install -d ${D}${PTEST_PATH}/tests |
| 21 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 22 | } |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | |
| 24 | RDEPENDS_${PN} += "python3-simplejson python3-math" |
| 25 | |
| 26 | BBCLASSEXTEND = "native nativesdk" |