Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "File transport adapter for Requests" |
| 2 | HOMEPAGE = "http://github.com/dashea/requests-file" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9cc728d6087e43796227b0a31422de6b" |
| 5 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 6 | SRC_URI[md5sum] = "c96daf6b0c56687556e8a52748fd896c" |
| 7 | SRC_URI[sha256sum] = "07d74208d3389d01c38ab89ef403af0cfec63957d53a0081d8eca738d0247d8e" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | |
Andrew Geissler | 748a483 | 2020-07-24 16:24:21 -0500 | [diff] [blame] | 9 | inherit pypi setuptools3 ptest |
| 10 | |
| 11 | SRC_URI += " \ |
| 12 | file://run-ptest \ |
| 13 | " |
| 14 | |
| 15 | RDEPENDS_${PN}-ptest += " \ |
| 16 | ${PYTHON_PN}-pytest \ |
| 17 | " |
| 18 | |
| 19 | do_install_ptest() { |
| 20 | install -d ${D}${PTEST_PATH}/tests |
| 21 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 22 | } |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | |
| 24 | RDEPENDS_${PN} += " \ |
| 25 | python3-requests \ |
| 26 | " |
| 27 | |