Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | # This recipe is originally from meta-openstack: |
| 2 | # https://git.yoctoproject.org/cgit/cgit.cgi/meta-cloud-services/tree/meta-openstack/recipes-devtools/python/python3-uritemplate_3.0.0.bb?h=master |
| 3 | |
| 4 | SUMMARY = "Simple python library to deal with URI Templates." |
| 5 | AUTHOR = "Ian Cordasco" |
| 6 | LICENSE = "Apache-2.0 | BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0f6d769bdcfacac3c1a1ffa568937fe0" |
| 8 | |
| 9 | SRC_URI[md5sum] = "869fb44fbd56713490db7272eb36c8ae" |
| 10 | SRC_URI[sha256sum] = "5af8ad10cec94f215e3f48112de2022e1d5a37ed427fbd88652fa908f2ab7cae" |
| 11 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 12 | inherit pypi setuptools3 ptest |
| 13 | |
| 14 | SRC_URI += " \ |
| 15 | file://run-ptest \ |
| 16 | " |
| 17 | |
| 18 | RDEPENDS_${PN}-ptest += " \ |
| 19 | ${PYTHON_PN}-pytest \ |
| 20 | " |
| 21 | |
| 22 | do_install_ptest() { |
| 23 | install -d ${D}${PTEST_PATH}/tests |
| 24 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 25 | } |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |