Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "A golang registry for global request variables." |
| 2 | HOMEPAGE = "https://github.com/go-fsnotify/fsnotify" |
| 3 | SECTION = "devel/go" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c38914c9a7ab03bb2b96d4baaee10769" |
| 6 | |
| 7 | SRCNAME = "fsnotify" |
| 8 | |
| 9 | PKG_NAME = "github.com/go-fsnotify/${SRCNAME}" |
| 10 | SRC_URI = "git://${PKG_NAME}.git" |
| 11 | |
| 12 | SRCREV = "ca50e738d35a862c379baf8fffbc3bfd080b3cff" |
| 13 | PV = "1.0.4+git${SRCREV}" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | do_install() { |
| 18 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} |
| 19 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ |
| 20 | } |
| 21 | |
| 22 | SYSROOT_PREPROCESS_FUNCS += "go_fsnotify_sysroot_preprocess" |
| 23 | |
| 24 | go_fsnotify_sysroot_preprocess () { |
| 25 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} |
| 26 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) |
| 27 | } |
| 28 | |
| 29 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" |