Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Gammu bindings for Python" |
| 2 | DESCRIPTION ="Python bindings for the Gammu library." |
| 3 | HOMEPAGE = "https://wammu.eu/python-gammu/" |
| 4 | BUGRACKER = "https://github.com/gammu/python-gammu/issues" |
| 5 | LICENSE = "GPL-2.0-or-later" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | PYPI_PACKAGE = "python-gammu" |
| 9 | |
| 10 | inherit pypi setuptools3 pkgconfig |
| 11 | |
| 12 | SRC_URI += "file://0001-setup.py-StrictVersion-packaging.version.patch" |
| 13 | SRC_URI[sha256sum] = "49fc70f01bc192c43ff3ec815e082df5261ea4c8d36a695e977734c4eb4df868" |
| 14 | |
| 15 | S = "${WORKDIR}/python-gammu-${PV}" |
| 16 | |
| 17 | DEPENDS += "gammu python3-packaging-native" |
| 18 | |
| 19 | RDEPENDS:${PN} += "python3-asyncio python3-core python3-threading" |
| 20 | |
| 21 | RRECOMMENDS:${PN} += "gammu" |