Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Python WBEM Client and Provider Interface" |
| 2 | DESCRIPTION = "\ |
| 3 | A Python library for making CIM (Common Information Model) operations over \ |
| 4 | HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \ |
| 5 | WBEM client should be easy to use and not necessarily require a large amount \ |
| 6 | of programming knowledge. It is suitable for a large range of tasks from \ |
| 7 | simply poking around to writing web and GUI applications. \ |
| 8 | \ |
| 9 | WBEM, or Web Based Enterprise Management is a manageability protocol, like \ |
| 10 | SNMP, standardised by the Distributed Management Task Force (DMTF) available \ |
| 11 | at http://www.dmtf.org/standards/wbem. \ |
| 12 | \ |
| 13 | It also provides a Python provider interface, and is the fastest and easiest \ |
| 14 | way to write providers on the planet." |
| 15 | HOMEPAGE = "http://pywbem.github.io" |
| 16 | LICENSE = "LGPLv2.1" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 17 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 19 | SRC_URI[sha256sum] = "2abb6443f4debae56af7abefadb9fa5b8af9b53fc9bcf67f6c01a78db1064300" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 21 | inherit pypi setuptools3 update-alternatives |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 22 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | DEPENDS += " \ |
| 24 | ${PYTHON_PN}-ply-native \ |
| 25 | ${PYTHON_PN}-pyyaml-native \ |
| 26 | ${PYTHON_PN}-six-native \ |
| 27 | " |
| 28 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | RDEPENDS_${PN}_class-target += "\ |
| 30 | ${PYTHON_PN}-datetime \ |
| 31 | ${PYTHON_PN}-io \ |
| 32 | ${PYTHON_PN}-netclient \ |
| 33 | ${PYTHON_PN}-ply \ |
| 34 | ${PYTHON_PN}-pyyaml \ |
| 35 | ${PYTHON_PN}-six \ |
| 36 | ${PYTHON_PN}-stringold \ |
| 37 | ${PYTHON_PN}-threading \ |
| 38 | ${PYTHON_PN}-unixadmin \ |
| 39 | ${PYTHON_PN}-xml \ |
| 40 | " |
| 41 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 42 | ALTERNATIVE_${PN} = "mof_compiler" |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 43 | ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler" |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 44 | |
| 45 | ALTERNATIVE_PRIORITY = "60" |
| 46 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 47 | BBCLASSEXTEND = "native" |