Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "Tool to access UFS (Universal Flash Storage) devices" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
| 4 | |
| 5 | PV = "1.3+git${SRCPV}" |
| 6 | |
| 7 | BRANCH ?= "dev" |
| 8 | |
| 9 | SRCREV = "8b00e33003b57d7071943f63863fcf8cc48d5be9" |
| 10 | |
| 11 | SRC_URI = "git://github.com/westerndigitalcorporation/ufs-tool.git;protocol=git;branch=${BRANCH}" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame^] | 15 | EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}" CFLAGS="${CFLAGS}"" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 16 | |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame^] | 17 | do_configure() { |
| 18 | sed -i -e "s|-static$||g" ${S}/Makefile |
| 19 | } |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 20 | do_install() { |
| 21 | install -d ${D}${bindir}/ |
| 22 | install -c -m 755 ${S}/ufs-tool ${D}${bindir}/ |
| 23 | } |