Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Simple DirectMedia Layer image library" |
| 2 | SECTION = "libs" |
| 3 | |
| 4 | LICENSE = "Zlib" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=613734b7586e1580ef944961c6d62227" |
| 6 | |
| 7 | DEPENDS = "tiff zlib libpng jpeg virtual/libsdl" |
| 8 | |
| 9 | SRC_URI = "http://www.libsdl.org/projects/SDL_image/release/SDL_image-${PV}.tar.gz \ |
| 10 | file://configure.patch" |
| 11 | SRC_URI[md5sum] = "a0f9098ebe5400f0bdc9b62e60797ecb" |
| 12 | SRC_URI[sha256sum] = "0b90722984561004de84847744d566809dbb9daf732a9e503b91a1b5a84e5699" |
| 13 | |
| 14 | S = "${WORKDIR}/SDL_image-${PV}" |
| 15 | |
| 16 | inherit autotools pkgconfig |
| 17 | |
| 18 | export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config" |
| 19 | |
| 20 | # Disable the run-time loading of the libs and bring back the soname dependencies. |
| 21 | EXTRA_OECONF += "--disable-jpg-shared --disable-png-shared -disable-tif-shared" |
| 22 | |
| 23 | do_configure_prepend() { |
| 24 | # Removing these files fixes a libtool version mismatch. |
| 25 | rm -f ${S}/acinclude/libtool.m4 |
| 26 | rm -f ${S}/acinclude/sdl.m4 |
| 27 | rm -f ${S}/acinclude/pkg.m4 |
| 28 | rm -f ${S}/acinclude/lt~obsolete.m4 |
| 29 | rm -f ${S}/acinclude/ltoptions.m4 |
| 30 | rm -f ${S}/acinclude/ltsugar.m4 |
| 31 | rm -f ${S}/acinclude/ltversion.m4 |
| 32 | } |