Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "The GNU Compact Disc Input and Control library (libcdio) contains a library for CD-ROM and CD image access." |
| 2 | HOMEPAGE = "http://www.gnu.org/software/libcdio/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "GPLv3+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 6 | |
| 7 | SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.bz2" |
| 8 | |
| 9 | SRC_URI[md5sum] = "aa7629e8f73662a762f64c444b901055" |
| 10 | SRC_URI[sha256sum] = "8550e9589dbd594bfac93b81ecf129b1dc9d0d51e90f9696f1b2f9b2af32712b" |
| 11 | |
| 12 | inherit autotools pkgconfig |
| 13 | |
| 14 | PACKAGECONFIG ??= "cdda-player" |
| 15 | PACKAGECONFIG[cdda-player] = "--with-cdda-player,--without-cdda-player,ncurses" |
| 16 | PACKAGECONFIG[cddb] = "--enable-cddb,--disable-cddb,libcddb" |
| 17 | PACKAGECONFIG[vcd-info] = "--enable-vcd-info,--disable-vcd-info,vcdimager" |
| 18 | |
| 19 | PACKAGES += "${PN}-utils" |
| 20 | |
| 21 | FILES_${PN} = "${libdir}/${BPN}${SOLIB}" |
| 22 | FILES_${PN}-utils = "${bindir}/*" |
| 23 | |
| 24 | python libcdio_split_packages() { |
| 25 | libdir = d.expand('${libdir}') |
| 26 | do_split_packages(d, libdir, '^lib(.*)\.so\..*', 'lib%s', 'libcdio %s library', extra_depends='', allow_links=True) |
| 27 | } |
| 28 | |
| 29 | PACKAGESPLITFUNCS =+ "libcdio_split_packages" |