Vishwanatha Subbanna | 3de8405 | 2017-04-28 15:35:10 +0530 | [diff] [blame] | 1 | SUMMARY = "OpenPOWER Host checkstop monitor application" |
| 2 | PR = "r1" |
Brad Bishop | 2879d32 | 2018-11-07 14:45:23 -0500 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
Brad Bishop | 1ebdb61 | 2019-09-13 12:18:25 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Vishwanatha Subbanna | 3de8405 | 2017-04-28 15:35:10 +0530 | [diff] [blame] | 5 | |
| 6 | inherit obmc-phosphor-systemd |
Vishwanatha Subbanna | 3de8405 | 2017-04-28 15:35:10 +0530 | [diff] [blame] | 7 | inherit allarch |
| 8 | |
| 9 | DEPENDS += "virtual/obmc-gpio-monitor" |
| 10 | RDEPENDS_${PN} += "virtual/obmc-gpio-monitor" |
| 11 | |
| 12 | # For now, monitoring checkstop is the only usecase |
| 13 | OBMC_HOST_MONITOR_INSTANCES = "checkstop" |
| 14 | |
| 15 | # Copies config file having arguments for monitoring host checkstop |
| 16 | # via GPIO assertion |
| 17 | SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/checkstop" |
| 18 | |
Vishwanatha Subbanna | a1f486e | 2017-07-26 16:41:03 +0530 | [diff] [blame] | 19 | # This package is not supplying the unit file and also this is not a native |
| 20 | # recipe since state-mgmt needs this package at runtime. Unsetting this below |
| 21 | # variable will let the build go through |
| 22 | SYSTEMD_SERVICE_${PN} ?="" |
Vishwanatha Subbanna | 3de8405 | 2017-04-28 15:35:10 +0530 | [diff] [blame] | 23 | |
Vishwanatha Subbanna | a1f486e | 2017-07-26 16:41:03 +0530 | [diff] [blame] | 24 | # Install the override to set up a Conflicts relation |
| 25 | SYSTEMD_OVERRIDE_${PN} +="checkstop.conf:phosphor-gpio-monitor@checkstop.service.d/checkstop.conf" |
| 26 | |
Andrew Geissler | 5c76e0c | 2018-03-27 13:56:26 -0700 | [diff] [blame] | 27 | STATES = "startmin" |
Vishwanatha Subbanna | a1f486e | 2017-07-26 16:41:03 +0530 | [diff] [blame] | 28 | GPIO_MONITOR_TMPL = "phosphor-gpio-monitor@.service" |
| 29 | GPIO_MONITOR_TGTFMT = "phosphor-gpio-monitor@{1}.service" |
| 30 | CHECKSTOP_MONITOR_FMT = "../${GPIO_MONITOR_TMPL}:obmc-host-{0}@{2}.target.wants/${GPIO_MONITOR_TGTFMT}" |
Vishwanatha Subbanna | d521ee6 | 2017-06-07 21:00:16 +0530 | [diff] [blame] | 31 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CHECKSTOP_MONITOR_FMT', 'STATES', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}" |