Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Ninja is a small build system with a focus on speed." |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 2 | HOMEPAGE = "https://ninja-build.org/" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame^] | 3 | DESCRIPTION = "Ninja is a small build system with a focus on speed. It differs from other build systems in two major respects: it is designed to have its input files generated by a higher-level build system, and it is designed to run builds as fast as possible." |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e" |
| 6 | |
| 7 | DEPENDS = "re2c-native ninja-native" |
| 8 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 9 | SRCREV = "e72d1d581c945c158ed68d9bc48911063022a2c6" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
| 11 | SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release" |
| 12 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | do_configure[noexec] = "1" |
| 17 | |
| 18 | do_compile_class-native() { |
| 19 | python3 ./configure.py --bootstrap |
| 20 | } |
| 21 | |
| 22 | do_compile() { |
| 23 | python3 ./configure.py |
| 24 | ninja |
| 25 | } |
| 26 | |
| 27 | do_install() { |
| 28 | install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja |
| 29 | } |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |