Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Library and test program for decoding MPEG-2 and MPEG-1 video streams" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame^] | 2 | DESCRIPTION = "mpeg2dec is a test program for libmpeg2. It decodes \ |
| 3 | mpeg-1 and mpeg-2 video streams, and also includes a demultiplexer \ |
| 4 | for mpeg-1 and mpeg-2 program streams. The main purpose of mpeg2dec \ |
| 5 | is to have a simple test bed for libmpeg2." |
| 6 | HOMEPAGE = "https://libmpeg2.sourceforge.io/" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 7 | SECTION = "libs" |
| 8 | LICENSE = "GPLv2+" |
| 9 | LICENSE_FLAGS = "commercial" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 11 | file://include/mpeg2.h;beginline=1;endline=22;md5=7766f4fcb58f0f8413c49a746f2ab89b" |
| 12 | |
| 13 | SRC_URI = "http://libmpeg2.sourceforge.net/files/libmpeg2-${PV}.tar.gz \ |
| 14 | file://altivec_h_needed.patch \ |
| 15 | file://0001-check-for-available-arm-optimizations.patch \ |
| 16 | file://0002-Set-visibility-of-global-symbols-used-in-ARM-specifi.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | file://61_global-symbol-test.patch \ |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 18 | file://0001-Import-revision-1206-from-upstream-to-fix-PIE-build.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 19 | " |
| 20 | |
| 21 | S = "${WORKDIR}/libmpeg2-${PV}" |
| 22 | |
| 23 | SRC_URI[md5sum] = "0f92c7454e58379b4a5a378485bbd8ef" |
| 24 | SRC_URI[sha256sum] = "dee22e893cb5fc2b2b6ebd60b88478ab8556cb3b93f9a0d7ce8f3b61851871d4" |
| 25 | |
| 26 | UPSTREAM_CHECK_URI = "http://libmpeg2.sourceforge.net/downloads.html" |
| 27 | |
| 28 | inherit autotools pkgconfig |
| 29 | |
| 30 | EXTRA_OECONF = "--enable-shared --disable-sdl" |
| 31 | |
| 32 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
| 33 | PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 libxext libxv" |
| 34 | |
| 35 | PACKAGES = "mpeg2dec-dbg mpeg2dec mpeg2dec-doc libmpeg2 libmpeg2-dev libmpeg2convert libmpeg2convert-dev libmpeg2-staticdev libmpeg2convert-staticdev" |
| 36 | |
| 37 | FILES_${PN} = "${bindir}/*" |
| 38 | FILES_libmpeg2 = "${libdir}/libmpeg2.so.*" |
| 39 | FILES_libmpeg2convert = "${libdir}/libmpeg2convert.so.*" |
| 40 | FILES_libmpeg2-dev = "${libdir}/libmpeg2.so \ |
| 41 | ${libdir}/libmpeg2.la \ |
| 42 | ${libdir}/libmpeg2arch.la \ |
| 43 | ${libdir}/pkgconfig/libmpeg2.pc \ |
| 44 | ${includedir}/mpeg2dec/mpeg2.h" |
| 45 | FILES_libmpeg2-staticdev = "${libdir}/libmpeg2.a" |
| 46 | FILES_libmpeg2convert-dev = "${libdir}/libmpeg2convert.so \ |
| 47 | ${libdir}/libmpeg2convert.la \ |
| 48 | ${libdir}/libmpeg2convertarch.la \ |
| 49 | ${libdir}/pkgconfig/libmpeg2convert.pc \ |
| 50 | ${includedir}/mpeg2dec/mpeg2convert.h" |
| 51 | FILES_libmpeg2convert-staticdev = "${libdir}/libmpeg2convert.a" |