Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Userspace library to access USB (version 1.0)" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame^] | 2 | DESCRIPTION = "A cross-platform library to access USB devices from Linux, \ |
| 3 | macOS, Windows, OpenBSD/NetBSD, Haiku and Solaris userspace." |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 4 | HOMEPAGE = "http://libusb.sf.net" |
| 5 | BUGTRACKER = "http://www.libusb.org/report" |
| 6 | SECTION = "libs" |
| 7 | |
| 8 | LICENSE = "LGPLv2.1+" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" |
| 10 | |
| 11 | BBCLASSEXTEND = "native nativesdk" |
| 12 | |
| 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-${PV}.tar.bz2 \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 17 | SRC_URI[sha256sum] = "7efd2685f7b327326dcfb85cee426d9b871fd70e22caa15bb68d595ce2a2b12a" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/libusb-${PV}" |
| 20 | |
| 21 | inherit autotools pkgconfig ptest |
| 22 | |
| 23 | PACKAGECONFIG_class-target ??= "udev" |
| 24 | PACKAGECONFIG[udev] = "--enable-udev,--disable-udev,udev" |
| 25 | |
| 26 | EXTRA_OECONF = "--libdir=${base_libdir}" |
| 27 | |
| 28 | do_install_append() { |
| 29 | install -d ${D}${libdir} |
| 30 | if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then |
| 31 | mv ${D}${base_libdir}/pkgconfig ${D}${libdir} |
| 32 | fi |
| 33 | } |
| 34 | |
| 35 | do_compile_ptest() { |
| 36 | oe_runmake -C tests stress |
| 37 | } |
| 38 | |
| 39 | do_install_ptest() { |
| 40 | install -m 755 ${B}/tests/.libs/stress ${D}${PTEST_PATH} |
| 41 | } |
| 42 | |
| 43 | FILES_${PN} += "${base_libdir}/*.so.*" |
| 44 | |
| 45 | FILES_${PN}-dev += "${base_libdir}/*.so ${base_libdir}/*.la" |