Patrick Rudolph | 2ca66a7 | 2023-05-08 08:36:57 +0200 | [diff] [blame] | 1 | SUMMARY = "YAML configuration for IBM Genesis3" |
| 2 | PR = "r1" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 5 | |
| 6 | inherit allarch |
| 7 | |
| 8 | SRC_URI:genesis3 = " \ |
| 9 | file://genesis3-ipmi-fru.yaml \ |
| 10 | file://genesis3-ipmi-fru-properties.yaml \ |
| 11 | " |
| 12 | |
| 13 | S = "${WORKDIR}" |
| 14 | |
| 15 | do_install:genesis3() { |
| 16 | install -m 0644 -D genesis3-ipmi-fru.yaml \ |
| 17 | ${D}${datadir}/${BPN}/ipmi-fru-read.yaml |
| 18 | install -m 0644 -D genesis3-ipmi-fru-properties.yaml \ |
| 19 | ${D}${datadir}/${BPN}/ipmi-extra-properties.yaml |
| 20 | } |
| 21 | |
| 22 | FILES:${PN}-dev = " \ |
| 23 | ${datadir}/${BPN}/ipmi-fru-read.yaml \ |
| 24 | ${datadir}/${BPN}/ipmi-extra-properties.yaml \ |
| 25 | " |
| 26 | |
| 27 | ALLOW_EMPTY:${PN} = "1" |