Lancelot Kao | 775cc0a | 2021-02-22 22:48:15 -0600 | [diff] [blame] | 1 | SUMMARY = "Power Cycle by Hotswap Controller" |
| 2 | DESCRIPTION = "Power Cycle by Hotswap Controller Daemon" |
| 3 | PR = "r1" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | inherit systemd |
| 8 | |
| 9 | DEPENDS += "systemd" |
Mohaimen Alsamarai | f59d017 | 2021-08-17 09:34:22 -0500 | [diff] [blame] | 10 | RDEPENDS:${PN} += "bash" |
Lancelot Kao | 775cc0a | 2021-02-22 22:48:15 -0600 | [diff] [blame] | 11 | |
Mohaimen Alsamarai | f59d017 | 2021-08-17 09:34:22 -0500 | [diff] [blame] | 12 | FILESEXTRAPATHS:prepend := "${THISDIR}/files:" |
| 13 | SRC_URI:append:kudo = " file://hotswap-power-cycle.service" |
Lancelot Kao | 775cc0a | 2021-02-22 22:48:15 -0600 | [diff] [blame] | 14 | |
| 15 | do_install() { |
| 16 | install -d ${D}${systemd_unitdir}/system/ |
| 17 | install -m 0644 ${WORKDIR}/hotswap-power-cycle.service ${D}${systemd_unitdir}/system/hotswap-power-cycle.service |
| 18 | } |
| 19 | |
| 20 | SYSTEMD_PACKAGES = "${PN}" |
Mohaimen Alsamarai | f59d017 | 2021-08-17 09:34:22 -0500 | [diff] [blame] | 21 | SYSTEMD_SERVICE:${PN} = " hotswap-power-cycle.service" |