Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "High Availability monitor built upon LVS, VRRP and service pollers" |
| 2 | DESCRIPTION = "Keepalived is a routing software written in C. The main goal \ |
| 3 | of this project is to provide simple and robust facilities for loadbalancing \ |
| 4 | and high-availability to Linux system and Linux based infrastructures. \ |
| 5 | Loadbalancing framework relies on well-known and widely used Linux Virtual \ |
| 6 | Server (IPVS) kernel module providing Layer4 loadbalancing \ |
| 7 | " |
| 8 | HOMEPAGE = "http://www.keepalived.org/" |
| 9 | |
| 10 | LICENSE = "GPLv2" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 12 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 13 | SRC_URI = "http://www.keepalived.org/software/${BP}.tar.gz \ |
| 14 | file://0001-layer4-Change-order-of-include-files.patch \ |
| 15 | " |
| 16 | SRC_URI[sha256sum] = "103692bd5345a4ed9f4581632ea636214fdf53e45682e200aab122c4fa674ece" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 17 | UPSTREAM_CHECK_URI = "https://github.com/acassen/keepalived/releases" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
| 19 | DEPENDS = "libnfnetlink openssl" |
| 20 | |
| 21 | inherit autotools pkgconfig systemd |
| 22 | |
| 23 | PACKAGECONFIG ??= "libnl snmp \ |
| 24 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 25 | " |
| 26 | PACKAGECONFIG[libnl] = "--enable-libnl,--disable-libnl,libnl" |
| 27 | PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp" |
| 28 | PACKAGECONFIG[systemd] = "--with-init=systemd --with-systemdsystemunitdir=${systemd_system_unitdir},--with-init=SYSV,systemd" |
| 29 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | EXTRA_OEMAKE = "initdir=${sysconfdir}/init.d" |
| 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | do_install:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 33 | if [ -f ${D}${sysconfdir}/init.d/${BPN} ]; then |
| 34 | chmod 0755 ${D}${sysconfdir}/init.d/${BPN} |
| 35 | sed -i 's#rc.d/##' ${D}${sysconfdir}/init.d/${BPN} |
| 36 | fi |
| 37 | |
| 38 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 39 | install -D -m 0644 ${B}/${BPN}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service |
| 40 | fi |
| 41 | } |
| 42 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 43 | FILES:${PN} += "${datadir}/snmp/mibs/KEEPALIVED-MIB.txt" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 44 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | SYSTEMD_SERVICE:${PN} = "keepalived.service" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 46 | SYSTEMD_AUTO_ENABLE ?= "disable" |