Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Test vectors for the cryptography package." |
| 2 | HOMEPAGE = "https://cryptography.io/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "Apache-2.0 | BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \ |
| 6 | file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \ |
| 7 | file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b" |
| 8 | |
| 9 | # NOTE: Make sure to keep this recipe at the same version as python3-cryptography |
| 10 | # Upgrade both recipes at the same time |
| 11 | |
| 12 | SRC_URI[sha256sum] = "fc8490afd5424342b868215435bd174dcd76ab396b4ea9435498be5721dcd598" |
| 13 | |
| 14 | PYPI_PACKAGE = "cryptography_vectors" |
| 15 | |
| 16 | inherit pypi setuptools3 |
| 17 | |
| 18 | DEPENDS += " \ |
| 19 | ${PYTHON_PN}-cryptography \ |
| 20 | " |
| 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |
| 23 | |
| 24 | UPSTREAM_CHECK_REGEX = "" |