Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 1 | SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)" |
| 2 | HOMEPAGE = "https://github.com/python/mypy" |
| 3 | LICENSE = "MIT & Python-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=17b7180fcfc43c4e70c07c71588604c4" |
| 5 | |
| 6 | PYPI_PACKAGE = "mypy" |
| 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
| 10 | SRC_URI[sha256sum] = "704098302473cb31a218f1775a873b376b30b4c18229421e9e9dc8916fd16150" |
| 11 | |
| 12 | BBCLASSEXTEND = "native" |
| 13 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 14 | RDEPENDS:${PN} += " \ |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 15 | ${PYTHON_PN}-mypy-extensions \ |
| 16 | ${PYTHON_PN}-typed-ast \ |
| 17 | ${PYTHON_PN}-typing-extensions \ |
| 18 | ${PYTHON_PN}-json \ |
| 19 | ${PYTHON_PN}-compression \ |
| 20 | ${PYTHON_PN}-pprint \ |
| 21 | ${PYTHON_PN}-difflib \ |
| 22 | ${PYTHON_PN}-toml \ |
| 23 | " |