Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "JSON Web Token implementation in Python" |
| 2 | DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\ |
| 3 | Original implementation was written by https://github.com/progrium" |
| 4 | HOMEPAGE = "http://github.com/jpadilla/pyjwt" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=68626705a7b513ca8d5f44a3e200ed0c" |
| 7 | |
| 8 | SRC_URI[sha256sum] = "b888b4d56f06f6dcd777210c334e69c737be74755d3e5e9ee3fe67dc18a0ee41" |
| 9 | |
| 10 | PYPI_PACKAGE = "PyJWT" |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | RDEPENDS:${PN} = "${PYTHON_PN}-cryptography" |
| 14 | |
| 15 | BBCLASSEXTEND = "native nativesdk" |