Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Bindings for the scrypt key derivation function library" |
| 2 | LICENSE = "BSD-2-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=05b5ac2824a7ae7489193b0f6a6f2cd1" |
| 4 | HOMEPAGE="https://github.com/holgern/py-scrypt" |
| 5 | |
| 6 | SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch" |
| 7 | |
| 8 | SRC_URI[sha256sum] = "ad143035ae0cf5e97c4b399f4e4686adf442c5f0f06f9f198a0cc6c091335fb7" |
| 9 | |
| 10 | inherit pypi ptest setuptools3 dos2unix |
| 11 | |
| 12 | SRC_URI += " \ |
| 13 | file://run-ptest \ |
| 14 | " |
| 15 | |
| 16 | RDEPENDS:${PN}-ptest += " \ |
| 17 | ${PYTHON_PN}-pytest \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS:${PN} += " \ |
| 21 | ${PYTHON_PN}-ctypes \ |
| 22 | " |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | install -d ${D}${PTEST_PATH}/tests |
| 26 | cp -rf ${S}/scrypt/tests/* ${D}${PTEST_PATH}/tests/ |
| 27 | } |