Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Setuptools Rust extension plugin" |
| 2 | DESCRIPTION = "setuptools-rust is a plugin for setuptools to build Rust \ |
| 3 | Python extensions implemented with PyO3 or rust-cpython.\ |
| 4 | \ |
| 5 | Compile and distribute Python extensions written in Rust as easily as if they were written in C." |
| 6 | HOMEPAGE = "https://github.com/PyO3/setuptools-rust" |
| 7 | BUGTRACKER = "https://github.com/PyO3/setuptools-rust/issues" |
| 8 | |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5" |
| 11 | |
| 12 | SRC_URI = "https://files.pythonhosted.org/packages/67/08/e1aa2c582c62ac76e4d60f8e454bd3bba933781a06a88b4e38797445822a/setuptools-rust-${PV}.tar.gz" |
| 13 | SRC_URI[sha256sum] = "a0adb9b503c0ffc4e8fe80b7c617898cefa78049983aaaea7f747e153a3e65d1" |
| 14 | |
| 15 | inherit cargo pypi setuptools3 native |
| 16 | |
| 17 | DEPENDS += "python3-setuptools-scm-native python3-wheel-native" |
| 18 | |
| 19 | RDEPENDS:${PN}:class-native += " \ |
| 20 | python3-semantic-version-native \ |
| 21 | python3-setuptools-native \ |
| 22 | python3-setuptools-scm-native \ |
| 23 | python3-toml-native \ |
| 24 | python3-typing-extensions-native \ |
| 25 | python3-wheel-native \ |
| 26 | " |