Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \ |
| 2 | Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \ |
| 3 | (including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more." |
| 4 | HOMEPAGE = "http://www.twistedmatrix.com" |
| 5 | |
| 6 | #twisted/topfiles/NEWS:655: - Relicensed: Now under the MIT license, rather than LGPL. |
| 7 | LICENSE = "MIT" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e33c411c0b86b1f3ca299091ed51ca31" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 9 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 10 | SRC_URI[sha256sum] = "2cd652542463277378b0d349f47c62f20d9306e57d1247baabd6d1d38a109006" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 11 | |
| 12 | PYPI_PACKAGE = "Twisted" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 13 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 14 | inherit pypi setuptools3 |
| 15 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 16 | do_install:append() { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 17 | # remove some useless files before packaging |
| 18 | find ${D} \( -name "*.bat" -o -name "*.c" -o -name "*.h" \) -exec rm -f {} \; |
| 19 | } |
| 20 | |
| 21 | PACKAGES += "\ |
| 22 | ${PN}-zsh \ |
| 23 | ${PN}-test \ |
| 24 | ${PN}-protocols \ |
| 25 | ${PN}-conch \ |
| 26 | ${PN}-mail \ |
| 27 | ${PN}-names \ |
| 28 | ${PN}-news \ |
| 29 | ${PN}-runner \ |
| 30 | ${PN}-web \ |
| 31 | ${PN}-words \ |
| 32 | ${PN}-flow \ |
| 33 | ${PN}-pair \ |
| 34 | ${PN}-core \ |
| 35 | " |
| 36 | |
| 37 | PACKAGES =+ "\ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 38 | ${PN}-bin \ |
| 39 | " |
| 40 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 41 | DEPENDS += " \ |
| 42 | ${PYTHON_PN}-incremental-native \ |
| 43 | " |
| 44 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | RDEPENDS:${PN} = "\ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 46 | ${PN}-bin \ |
| 47 | ${PN}-core \ |
| 48 | ${PN}-conch \ |
| 49 | ${PN}-mail \ |
| 50 | ${PN}-names \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 51 | ${PN}-pair \ |
| 52 | ${PN}-protocols \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 53 | ${PN}-runner \ |
| 54 | ${PN}-web \ |
| 55 | ${PN}-words \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 56 | ${PN}-zsh \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 57 | " |
| 58 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 59 | RDEPENDS:${PN}-core = "${PYTHON_PN}-appdirs \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 60 | ${PYTHON_PN}-automat \ |
| 61 | ${PYTHON_PN}-constantly \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 62 | ${PYTHON_PN}-core \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 63 | ${PYTHON_PN}-debugger \ |
| 64 | ${PYTHON_PN}-hyperlink \ |
| 65 | ${PYTHON_PN}-incremental \ |
| 66 | ${PYTHON_PN}-pyhamcrest \ |
| 67 | ${PYTHON_PN}-pyserial \ |
| 68 | ${PYTHON_PN}-unixadmin \ |
| 69 | ${PYTHON_PN}-zopeinterface \ |
| 70 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 71 | RDEPENDS:${PN}-test = "${PN}" |
| 72 | RDEPENDS:${PN}-conch = "${PN}-core ${PN}-protocols ${PYTHON_PN}-bcrypt ${PYTHON_PN}-cryptography ${PYTHON_PN}-pyasn1 ${PYTHON_PN}-pickle" |
| 73 | RDEPENDS:${PN}-mail = "${PN}-core ${PN}-protocols" |
| 74 | RDEPENDS:${PN}-names = "${PN}-core" |
| 75 | RDEPENDS:${PN}-news = "${PN}-core ${PN}-protocols" |
| 76 | RDEPENDS:${PN}-runner = "${PN}-core ${PN}-protocols" |
| 77 | RDEPENDS:${PN}-web += "${PN}-core ${PN}-protocols" |
| 78 | RDEPENDS:${PN}-words += "${PN}-core" |
| 79 | RDEPENDS:${PN}-flow += "${PN}-core" |
| 80 | RDEPENDS:${PN}-pair += "${PN}-core" |
| 81 | RDEPENDS:${PN}-dbg = "${PN}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 82 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 83 | ALLOW_EMPTY:${PN} = "1" |
| 84 | FILES:${PN} = "" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 85 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 86 | FILES:${PN}-test = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 87 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \ |
| 88 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \ |
| 89 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy/test/ \ |
| 90 | " |
| 91 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 92 | FILES:${PN}-protocols = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 93 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/*.py* \ |
| 94 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/gps/ \ |
| 95 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/mice/ \ |
| 96 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy \ |
| 97 | " |
| 98 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 99 | FILES:${PN}-zsh = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 100 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \ |
| 101 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \ |
| 102 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/twisted-completion.zsh \ |
| 103 | " |
| 104 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 105 | FILES:${PN}-conch = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 106 | ${bindir}/ckeygen \ |
| 107 | ${bindir}/tkconch \ |
| 108 | ${bindir}/conch \ |
| 109 | ${bindir}/conchftp \ |
| 110 | ${bindir}/cftp \ |
| 111 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \ |
| 112 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \ |
| 113 | " |
| 114 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 115 | FILES:${PN}-core = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 116 | ${bindir}/manhole \ |
| 117 | ${bindir}/mktap \ |
| 118 | ${bindir}/twistd \ |
| 119 | ${bindir}/tap2deb \ |
| 120 | ${bindir}/tap2rpm \ |
| 121 | ${bindir}/tapconvert \ |
| 122 | ${bindir}/tkmktap \ |
| 123 | ${bindir}/trial \ |
| 124 | ${bindir}/easy_install* \ |
| 125 | ${bindir}/pyhtmlizer \ |
| 126 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.so \ |
| 127 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \ |
| 128 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \ |
| 129 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \ |
| 130 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \ |
| 131 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \ |
| 132 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \ |
| 133 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \ |
| 134 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \ |
| 135 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \ |
| 136 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \ |
| 137 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \ |
| 138 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \ |
| 139 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/application \ |
| 140 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \ |
| 141 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/enterprise \ |
| 142 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/internet \ |
| 143 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \ |
| 144 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \ |
| 145 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \ |
| 146 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\ |
| 147 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python\ |
| 148 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \ |
| 149 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \ |
| 150 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \ |
| 151 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \ |
| 152 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \ |
| 153 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \ |
| 154 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \ |
| 155 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \ |
| 156 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \ |
| 157 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \ |
| 158 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \ |
| 159 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \ |
| 160 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \ |
| 161 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \ |
| 162 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \ |
| 163 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \ |
| 164 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \ |
| 165 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \ |
| 166 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \ |
| 167 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \ |
| 168 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \ |
| 169 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \ |
| 170 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \ |
| 171 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \ |
| 172 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \ |
| 173 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \ |
| 174 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \ |
| 175 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \ |
| 176 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \ |
| 177 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \ |
| 178 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \ |
| 179 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \ |
| 180 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \ |
| 181 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \ |
| 182 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \ |
| 183 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \ |
| 184 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \ |
| 185 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \ |
| 186 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \ |
| 187 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \ |
| 188 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \ |
| 189 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \ |
| 190 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \ |
| 191 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \ |
| 192 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \ |
| 193 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \ |
| 194 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \ |
| 195 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \ |
| 196 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \ |
| 197 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/topfiles \ |
| 198 | ${libdir}/${PYTHON_DIR}/site-packages/Twisted*egg-info \ |
| 199 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/logger/ \ |
| 200 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/_threads/ \ |
| 201 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/positioning/ \ |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 202 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/py.typed \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 203 | " |
| 204 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 205 | FILES:${PN}-mail = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 206 | ${bindir}/mailmail \ |
| 207 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \ |
| 208 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \ |
| 209 | " |
| 210 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 211 | FILES:${PN}-names = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 212 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \ |
| 213 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/names \ |
| 214 | " |
| 215 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 216 | FILES:${PN}-news = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 217 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \ |
| 218 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/news \ |
| 219 | " |
| 220 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 221 | FILES:${PN}-runner = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 222 | ${libdir}/site-packages/twisted/runner/portmap.so \ |
| 223 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\ |
| 224 | " |
| 225 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 226 | FILES:${PN}-web = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 227 | ${bindir}/websetroot \ |
| 228 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \ |
| 229 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/web\ |
| 230 | " |
| 231 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 232 | FILES:${PN}-words = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 233 | ${bindir}/im \ |
| 234 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \ |
| 235 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/words\ |
| 236 | " |
| 237 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 238 | FILES:${PN}-flow = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 239 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_flow.py* \ |
| 240 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/flow \" |
| 241 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 242 | FILES:${PN}-pair = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 243 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_pair.py* \ |
| 244 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/pair \ |
| 245 | " |
| 246 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 247 | FILES:${PN}-dbg += " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 248 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \ |
| 249 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \ |
| 250 | " |
| 251 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 252 | FILES:${PN}-doc += " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 253 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_pydoctortemplates/ \ |
| 254 | " |
| 255 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 256 | RDEPENDS:${PN}-src = "${PN}" |
| 257 | FILES:${PN}-src = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 258 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py \ |
| 259 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*.py \ |
| 260 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/*.py \ |
| 261 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 262 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 263 | FILES:${PN}-core:append = " \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 264 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \ |
| 265 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__pycache__/*pyc \ |
| 266 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/__init__*.pyc \ |
| 267 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/notestplugin*.pyc \ |
| 268 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/testplugin*.pyc \ |
| 269 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_ftp*.pyc \ |
| 270 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_inet*.pyc \ |
| 271 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_manhole*.pyc \ |
| 272 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_portforward*.pyc \ |
| 273 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_socks*.pyc \ |
| 274 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_telnet*.pyc \ |
| 275 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_trial*.pyc \ |
| 276 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_core*.pyc \ |
| 277 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_qtstub*.pyc \ |
| 278 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_reactors*.pyc \ |
| 279 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/cred*.pyc \ |
| 280 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/dropin*.cache \ |
| 281 | " |
| 282 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 283 | FILES:${PN}-names:append = " \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 284 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_names*.pyc \ |
| 285 | " |
| 286 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 287 | FILES:${PN}-news:append = " \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 288 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_news*.pyc \ |
| 289 | " |
| 290 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 291 | FILES:${PN}-protocols:append = " \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 292 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/__pycache__/*pyc \ |
| 293 | " |
| 294 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 295 | FILES:${PN}-conch:append = " \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 296 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_conch*.pyc \ |
| 297 | " |
| 298 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 299 | FILES:${PN}-lore:append = " \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 300 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_lore*.pyc \ |
| 301 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 302 | FILES:${PN}-mail:append = " \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 303 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_mail*.pyc \ |
| 304 | " |
| 305 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 306 | FILES:${PN}-web:append = " \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 307 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_web*.pyc \ |
| 308 | " |
| 309 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 310 | FILES:${PN}-words:append = " \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 311 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_words*.pyc \ |
| 312 | " |
| 313 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 314 | FILES:${PN}-flow:append = " \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 315 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_flow*.pyc \ |
| 316 | " |
| 317 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 318 | FILES:${PN}-pair:append = " \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 319 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_pair*.pyc \ |
| 320 | " |
| 321 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 322 | FILES:${PN}-runner:append = " \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 323 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_runner*.pyc \ |
| 324 | " |