Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 1 | SUMMARY = "Perl-cross build system" |
| 2 | HOMEPAGE = "https://github.com/arsv/perl-cross" |
| 3 | DESCRIPTION = "perl-cross provides configure script, top-level Makefile and some auxiliary files for perl, \ |
| 4 | with the primary emphasis on cross-compiling the source." |
| 5 | SECTION = "devel" |
| 6 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 7 | # README.md is taken from https://github.com/arsv/perl-cross/blob/master/README.md |
| 8 | # but is not provided inside the release tarballs |
| 9 | LIC_FILES_CHKSUM = "file://${WORKDIR}/README.md;md5=252fcce2026b765fee1ad74d2fb07a3b" |
| 10 | |
| 11 | inherit allarch |
| 12 | |
| 13 | SRC_URI = "https://github.com/arsv/perl-cross/releases/download/${PV}/perl-cross-${PV}.tar.gz;name=perl-cross \ |
| 14 | file://README.md \ |
| 15 | file://0001-configure_tool.sh-do-not-quote-the-argument-to-comma.patch \ |
| 16 | file://0001-perl-cross-add-LDFLAGS-when-linking-libperl.patch \ |
| 17 | file://0001-configure_path.sh-do-not-hardcode-prefix-lib-as-libr.patch \ |
| 18 | file://determinism.patch \ |
| 19 | file://0001-cnf-configure_func_sel.sh-disable-thread_safe_nl_lan.patch \ |
Andrew Geissler | 5f35090 | 2021-07-23 13:09:54 -0400 | [diff] [blame] | 20 | file://0001-Makefile-check-the-file-if-patched-or-not.patch \ |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 21 | " |
| 22 | UPSTREAM_CHECK_URI = "https://github.com/arsv/perl-cross/releases/" |
| 23 | |
| 24 | SRC_URI[perl-cross.sha256sum] = "4010f41870d64e3957b4b8ce70ebba10a7c4a3e86c5551acb4099c3fcbb37ce5" |
| 25 | |
| 26 | S = "${WORKDIR}/perl-cross-${PV}" |
| 27 | |
| 28 | do_configure () { |
| 29 | } |
| 30 | |
| 31 | do_compile () { |
| 32 | } |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | do_install:class-native() { |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 35 | mkdir -p ${D}/${datadir}/perl-cross/ |
| 36 | cp -rf ${S}/* ${D}/${datadir}/perl-cross/ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 37 | rm -rf ${D}/${datadir}/perl-cross/patches/ |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 38 | } |
| 39 | |
| 40 | BBCLASSEXTEND = "native" |
| 41 | |