Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Resolve JSON Pointers in Python" |
| 2 | HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3" |
| 5 | |
| 6 | inherit pypi ptest setuptools3 |
| 7 | |
| 8 | SRC_URI[sha256sum] = "f09f8deecaaa5aea65b5eb4f67ca4e54e1a61f7a11c75085e360fe6feb6a48bf" |
| 9 | |
| 10 | RDEPENDS:${PN} += " \ |
| 11 | ${PYTHON_PN}-json \ |
| 12 | " |
| 13 | |
| 14 | BBCLASSEXTEND = "native nativesdk" |
| 15 | |
| 16 | SRC_URI += " \ |
| 17 | file://run-ptest \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS:${PN}-ptest += " \ |
| 21 | ${PYTHON_PN}-pytest \ |
| 22 | " |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | cp -f ${S}/tests.py ${D}${PTEST_PATH}/ |
| 26 | } |