Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Simple powerful testing with python" |
| 2 | HOMEPAGE = "https://pypi.org/project/pytest/" |
| 3 | DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries." |
| 4 | |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b" |
| 7 | |
| 8 | SRC_URI[sha256sum] = "131b36680866a76e6781d13f101efb86cf674ebb9762eb70d3082b6f29889e89" |
| 9 | |
| 10 | DEPENDS = "python3-setuptools-scm-native" |
| 11 | |
| 12 | inherit update-alternatives pypi setuptools3 |
| 13 | |
| 14 | RDEPENDS:${PN}:class-target += " \ |
| 15 | ${PYTHON_PN}-atomicwrites \ |
| 16 | ${PYTHON_PN}-attrs \ |
| 17 | ${PYTHON_PN}-debugger \ |
| 18 | ${PYTHON_PN}-doctest \ |
| 19 | ${PYTHON_PN}-importlib-metadata \ |
| 20 | ${PYTHON_PN}-iniconfig \ |
| 21 | ${PYTHON_PN}-json \ |
| 22 | ${PYTHON_PN}-more-itertools \ |
| 23 | ${PYTHON_PN}-packaging \ |
| 24 | ${PYTHON_PN}-pathlib2 \ |
| 25 | ${PYTHON_PN}-pluggy \ |
| 26 | ${PYTHON_PN}-py \ |
| 27 | ${PYTHON_PN}-setuptools \ |
| 28 | ${PYTHON_PN}-six \ |
| 29 | ${PYTHON_PN}-toml \ |
| 30 | ${PYTHON_PN}-wcwidth \ |
| 31 | " |
| 32 | |
| 33 | ALTERNATIVE:${PN} += "py.test pytest" |
| 34 | |
| 35 | NATIVE_LINK_NAME[pytest] = "${bindir}/pytest" |
| 36 | ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest" |
| 37 | |
| 38 | ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test" |
| 39 | ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test" |
| 40 | |
| 41 | BBCLASSEXTEND = "native nativesdk" |