Willy Tu | 74a3a8a | 2021-02-10 09:52:53 -0800 | [diff] [blame] | 1 | PR = "r1" |
| 2 | |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 5 | |
| 6 | inherit systemd |
| 7 | |
| 8 | RDEPENDS_${PN} += "sslh" |
| 9 | |
| 10 | SRC_URI_append = " \ |
| 11 | file://sslh.service \ |
| 12 | file://sslh.socket \ |
| 13 | " |
| 14 | |
| 15 | SYSTEMD_SERVICE_${PN} += "sslh.service" |
| 16 | SYSTEMD_SERVICE_${PN} += "sslh.socket" |
| 17 | |
| 18 | do_install() { |
| 19 | # Install service definitions |
| 20 | install -d -m 0755 ${D}${systemd_system_unitdir} |
| 21 | install -m 0644 ${WORKDIR}/sslh.service ${D}${systemd_system_unitdir} |
| 22 | install -m 0644 ${WORKDIR}/sslh.socket ${D}${systemd_system_unitdir} |
| 23 | } |