Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Checksumming Copy on Write Filesystem utilities" |
| 2 | DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \ |
| 3 | implementing advanced features while focusing on fault tolerance, repair and \ |
| 4 | easy administration. \ |
| 5 | This package contains utilities (mkfs, fsck, btrfsctl) used to work with \ |
| 6 | btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3." |
| 7 | |
| 8 | HOMEPAGE = "https://btrfs.wiki.kernel.org" |
| 9 | |
| 10 | LICENSE = "GPLv2" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067" |
| 12 | SECTION = "base" |
| 13 | DEPENDS = "util-linux attr e2fsprogs lzo acl" |
| 14 | DEPENDS_append_class-target = " udev" |
| 15 | RDEPENDS_${PN} = "libgcc" |
| 16 | |
| 17 | SRCREV = "a7a1ea0f4f2a1d6eeeb3d106e062c7f1034f16d4" |
| 18 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \ |
| 19 | file://0001-Makefile-build-mktables-using-native-gcc.patch \ |
| 20 | file://0001-Fix-build-with-musl-missing-header-include-for-dev_t.patch \ |
| 21 | " |
| 22 | |
| 23 | RECIPE_NO_UPDATE_REASON = "Waiting for resolution of https://github.com/kdave/btrfs-progs/issues/109" |
| 24 | inherit autotools-brokensep pkgconfig manpages |
| 25 | |
| 26 | CLEANBROKEN = "1" |
| 27 | |
| 28 | PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native" |
| 29 | EXTRA_OECONF_append_libc-musl = " --disable-backtrace " |
| 30 | |
| 31 | do_configure_prepend() { |
| 32 | # Upstream doesn't ship this and autoreconf won't install it as automake isn't used. |
| 33 | mkdir -p ${S}/config |
| 34 | cp -f $(automake --print-libdir)/install-sh ${S}/config/ |
| 35 | } |
| 36 | |
| 37 | S = "${WORKDIR}/git" |
| 38 | |
| 39 | BBCLASSEXTEND = "native" |