Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | DESCRIPTION = "C implementation of createrepo." |
| 2 | HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki" |
| 3 | |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | SRC_URI = "git://github.com/rpm-software-management/createrepo_c \ |
| 8 | file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ |
| 9 | file://0001-Correctly-install-the-shared-library.patch \ |
| 10 | " |
| 11 | |
| 12 | PV = "0.10.0+git${SRCPV}" |
| 13 | SRCREV = "748891ff8ee524c2d37926c608cd2794f88013f3" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm" |
| 18 | DEPENDS_append_class-native = " file-replacement-native" |
| 19 | |
| 20 | inherit cmake pkgconfig bash-completion distutils3-base |
| 21 | |
| 22 | EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3" |
| 23 | |
| 24 | BBCLASSEXTEND = "native" |
| 25 | |
| 26 | # Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in |
| 27 | do_install_append_class-native() { |
| 28 | create_wrapper ${D}/${bindir}/createrepo_c \ |
| 29 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm |
| 30 | } |
| 31 | |