blob: c6fcfef3dd8725da9f4521f16f0236bba092875a [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Ninja is a small build system with a focus on speed."
2HOMEPAGE = "http://martine.github.com/ninja/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
5
6DEPENDS = "re2c-native ninja-native"
7
8SRCREV = "253e94c1fa511704baeb61cf69995bbf09ba435e"
9
10SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release"
11UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
12
13S = "${WORKDIR}/git"
14
15do_configure[noexec] = "1"
16
17do_compile_class-native() {
18 ./configure.py --bootstrap
19}
20
21do_compile() {
22 ./configure.py
23 ninja
24}
25
26do_install() {
27 install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja
28}
29
30BBCLASSEXTEND = "native nativesdk"