Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 1 | SUMMARY = "Bluetooth Audio ALSA Backend" |
| 2 | HOMEPAGE = "https://github.com/Arkq/bluez-alsa" |
| 3 | SECTION = "libs" |
| 4 | |
| 5 | LICENSE = "MIT" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8449a4f133a93f6254b496d4fb476e83" |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 7 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 8 | SRC_URI = "git://github.com/Arkq/bluez-alsa.git;protocol=https;branch=master" |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 9 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 10 | SRCREV = "dd05a1baa261b94da9ba977b5e3392c8b4dc7a5e" |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 11 | PV = "4.0.0+git" |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 15 | DEPENDS += "alsa-lib bluez5 dbus glib-2.0 sbc" |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 16 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 17 | PACKAGECONFIG ??= "aplay cli hcitop ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 18 | PACKAGECONFIG[a2dpconf] = "--enable-a2dpconf,--disable-a2dpconf" |
| 19 | PACKAGECONFIG[aac] = "--enable-aac,--disable-aac,fdk-aac" |
| 20 | PACKAGECONFIG[aplay] = "--enable-aplay,--disable-aplay" |
| 21 | PACKAGECONFIG[cli] = "--enable-cli,--disable-cli" |
| 22 | PACKAGECONFIG[coverage] = "--with-coverage,--without-coverage,lcov-native" |
| 23 | PACKAGECONFIG[debug] = "--enable-debug,--disable-debug" |
| 24 | PACKAGECONFIG[debug-time] = "--enable-debug-time,--disable-debug-time" |
| 25 | PACKAGECONFIG[faststream] = "--enable-faststream,--disable-faststream" |
| 26 | PACKAGECONFIG[hcitop] = "--enable-hcitop,--disable-hcitop,libbsd ncurses" |
| 27 | PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind" |
| 28 | PACKAGECONFIG[mp3lame] = "--enable-mp3lame,--disable-mp3lame,lame" |
| 29 | PACKAGECONFIG[mpg123] = "--enable-mpg123,--disable-mpg123,mpg123,mpg123" |
| 30 | PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono,ofono" |
| 31 | PACKAGECONFIG[payloadcheck] = "--enable-payloadcheck,--disable-payloadcheck" |
| 32 | PACKAGECONFIG[rfcomm] = "--enable-rfcomm,--disable-rfcomm" |
| 33 | PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_system_unitdir} \ |
| 34 | --with-systemdbluealsaargs='${SYSTEMD_BLUEALSA_ARGS}' --with-systemdbluealsaaplayargs='${SYSTEMD_BLUEALSA_APLAY_ARGS}',--disable-systemd,systemd" |
| 35 | PACKAGECONFIG[test] = "--enable-test,--disable-test,libcheck libsndfile1" |
| 36 | PACKAGECONFIG[upower] = "--enable-upower,--disable-upower,,upower" |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 37 | |
| 38 | inherit autotools pkgconfig systemd |
| 39 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 40 | EXTRA_OECONF = " \ |
| 41 | --disable-aptx \ |
| 42 | --disable-lc3plus \ |
| 43 | --disable-ldac \ |
| 44 | --disable-manpages \ |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 45 | " |
| 46 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 47 | PACKAGE_BEFORE_PN = "${PN}-aplay" |
| 48 | RRECOMMENDS:${PN} = "${PN}-aplay" |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 49 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 50 | FILES:${PN}-aplay = "${bindir}/bluealsa-aplay" |
| 51 | FILES:${PN} += "${libdir}/alsa-lib/*" |
| 52 | |
| 53 | SYSTEMD_PACKAGES += "${PN}-aplay" |
| 54 | SYSTEMD_SERVICE:${PN} = "bluealsa.service" |
| 55 | SYSTEMD_SERVICE:${PN}-aplay = "bluealsa-aplay.service" |
| 56 | |
| 57 | SYSTEMD_AUTO_ENABLE:${PN}-aplay = "disable" |
| 58 | |
| 59 | # Choose bluez-alsa arguments to be used in bluealsa systemd service |
| 60 | # Usually could choose profiles with it: a2dp-source a2dp-sink hfp-hf hfp-ag hsp-hs hsp-ag hfp-ofono |
| 61 | # Enable bluez-alsa arguments by default: |
| 62 | SYSTEMD_BLUEALSA_ARGS ?= "-p a2dp-source -p a2dp-sink" |
| 63 | |
| 64 | # Choose bluealsa-aplay arguments to be used in bluealsa-aplay systemd service |
| 65 | # Defaults to be empty: |
| 66 | SYSTEMD_BLUEALSA_APLAY_ARGS ?= "" |