Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # |
| 2 | # Creates a root filesystem out of rpm packages |
| 3 | # |
| 4 | |
| 5 | ROOTFS_PKGMANAGE = "rpm smartpm" |
| 6 | ROOTFS_PKGMANAGE_BOOTSTRAP = "run-postinsts" |
| 7 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 8 | # Add 100Meg of extra space for Smart |
| 9 | IMAGE_ROOTFS_EXTRA_SPACE_append = "${@bb.utils.contains("PACKAGE_INSTALL", "smartpm", " + 102400", "" ,d)}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 10 | |
| 11 | # Smart is python based, so be sure python-native is available to us. |
| 12 | EXTRANATIVEPATH += "python-native" |
| 13 | |
| 14 | # opkg is needed for update-alternatives |
| 15 | RPMROOTFSDEPENDS = "rpm-native:do_populate_sysroot \ |
| 16 | rpmresolve-native:do_populate_sysroot \ |
| 17 | python-smartpm-native:do_populate_sysroot \ |
| 18 | createrepo-native:do_populate_sysroot \ |
| 19 | opkg-native:do_populate_sysroot" |
| 20 | |
| 21 | do_rootfs[depends] += "${RPMROOTFSDEPENDS}" |
| 22 | do_populate_sdk[depends] += "${RPMROOTFSDEPENDS}" |
| 23 | |
| 24 | do_rootfs[recrdeptask] += "do_package_write_rpm" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 25 | do_rootfs[vardeps] += "PACKAGE_FEED_URIS" |
| 26 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 27 | python () { |
| 28 | if d.getVar('BUILD_IMAGES_FROM_FEEDS', True): |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 29 | flags = d.getVarFlag('do_rootfs', 'recrdeptask', True) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 30 | flags = flags.replace("do_package_write_rpm", "") |
| 31 | flags = flags.replace("do_deploy", "") |
| 32 | flags = flags.replace("do_populate_sysroot", "") |
| 33 | d.setVarFlag('do_rootfs', 'recrdeptask', flags) |
| 34 | d.setVar('RPM_PREPROCESS_COMMANDS', '') |
| 35 | d.setVar('RPM_POSTPROCESS_COMMANDS', '') |
| 36 | |
| 37 | } |
| 38 | # Smart is python based, so be sure python-native is available to us. |
| 39 | EXTRANATIVEPATH += "python-native" |
| 40 | |
| 41 | rpmlibdir = "/var/lib/rpm" |