Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Python bindings for the DBus inter-process communication system" |
| 2 | SECTION = "devel/python" |
| 3 | HOMEPAGE = "http://www.freedesktop.org/Software/dbus" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4" |
| 6 | DEPENDS = "expat dbus glib-2.0 virtual/libintl" |
| 7 | |
| 8 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz" |
| 9 | |
| 10 | SRC_URI[md5sum] = "51a45c973d82bedff033a4b57d69d5d8" |
| 11 | SRC_URI[sha256sum] = "11238f1d86c995d8aed2e22f04a1e3779f0d70e587caffeab4857f3c662ed5a4" |
| 12 | |
| 13 | S = "${WORKDIR}/dbus-python-${PV}" |
| 14 | |
| 15 | inherit distutils3-base autotools pkgconfig |
| 16 | |
| 17 | # documentation needs python3-sphinx, which is not in oe-core or meta-python for now |
| 18 | # change to use PACKAGECONFIG when python3-sphinx is added to oe-core |
| 19 | EXTRA_OECONF += "--disable-documentation" |
| 20 | |
| 21 | |
| 22 | RDEPENDS_${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml" |
| 23 | |
| 24 | FILES_${PN}-dev += "${libdir}/pkgconfig" |
| 25 | |
| 26 | BBCLASSEXTEND = "native nativesdk" |