Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Documentation system for on-line information and printed output" |
| 2 | DESCRIPTION = "Texinfo is a documentation system that can produce both \ |
| 3 | online information and printed output from a single source file. The \ |
| 4 | GNU Project uses the Texinfo file format for most of its documentation." |
| 5 | HOMEPAGE = "http://www.gnu.org/software/texinfo/" |
| 6 | SECTION = "console/utils" |
| 7 | LICENSE = "GPL-3.0-or-later" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464" |
| 9 | |
| 10 | PROVIDES:append:class-native = " texinfo-replacement-native" |
| 11 | |
| 12 | def compress_pkg(d): |
| 13 | if bb.data.inherits_class('compress_doc', d): |
| 14 | compress = d.getVar("DOC_COMPRESS") |
| 15 | if compress == "gz": |
| 16 | return "gzip" |
| 17 | elif compress == "bz2": |
| 18 | return "bzip2" |
| 19 | elif compress == "xz": |
| 20 | return "xz" |
| 21 | return "" |
| 22 | |
| 23 | RDEPENDS:info += "${@compress_pkg(d)}" |
| 24 | |
| 25 | DEPENDS = "zlib ncurses texinfo-replacement-native" |
| 26 | DEPENDS:class-native = "zlib-native ncurses-native" |
| 27 | |
| 28 | TARGET_PATCH = "file://use_host_makedoc.patch" |
| 29 | TARGET_PATCH:class-native = "" |
| 30 | |
| 31 | SRC_URI = "${GNU_MIRROR}/texinfo/${BP}.tar.gz \ |
| 32 | file://disable-native-tools.patch \ |
| 33 | file://link-zip.patch \ |
| 34 | file://dont-depend-on-help2man.patch \ |
| 35 | ${TARGET_PATCH} \ |
| 36 | " |
| 37 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 38 | SRC_URI[sha256sum] = "3cc5706fb086b895e1dc2b407aade9f95a3a233ff856273e2b659b089f117683" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 39 | |
| 40 | tex_texinfo = "texmf/tex/texinfo" |
| 41 | |
| 42 | inherit gettext autotools multilib_script |
| 43 | |
| 44 | MULTILIB_SCRIPTS = "${PN}:${bindir}/texi2any" |
| 45 | |
| 46 | EXTRA_AUTORECONF += "-I ${S}/gnulib/m4" |
| 47 | |
| 48 | do_configure:prepend () { |
| 49 | # autotools_do_configure updates po/Makefile.in.in, we also need |
| 50 | # update po_document. |
| 51 | cp -f ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po_document/ |
| 52 | } |
| 53 | |
| 54 | do_compile:prepend() { |
| 55 | if [ -d tools ];then |
| 56 | oe_runmake -C tools/gnulib/lib |
| 57 | fi |
| 58 | } |
| 59 | |
| 60 | do_install:append() { |
| 61 | mkdir -p ${D}${datadir}/${tex_texinfo} |
| 62 | install -p -m644 ${S}/doc/texinfo.tex ${S}/doc/txi-??.tex ${D}${datadir}/${tex_texinfo} |
| 63 | sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/texi2any ${D}${bindir}/pod2texi |
| 64 | sed -i -e 's,${HOSTTOOLS_DIR},,' ${D}${bindir}/texindex |
| 65 | } |
| 66 | |
| 67 | do_install:append:class-native() { |
| 68 | install -m 755 info/makedoc ${D}${bindir} |
| 69 | } |
| 70 | |
| 71 | PACKAGES += "info info-doc" |
| 72 | |
| 73 | FILES:info = "${bindir}/info ${bindir}/infokey ${bindir}/install-info" |
| 74 | FILES:info-doc = "${infodir}/info.info* ${infodir}/dir ${infodir}/info-*.info* \ |
| 75 | ${mandir}/man1/info.1* ${mandir}/man5/info.5* \ |
| 76 | ${mandir}/man1/infokey.1* ${mandir}/man1/install-info.1*" |
| 77 | |
| 78 | FILES:${PN} = "${bindir}/makeinfo ${bindir}/texi* ${bindir}/pdftexi2dvi ${bindir}/pod2texi ${datadir}/texinfo" |
| 79 | RDEPENDS:${PN} = "perl" |
| 80 | FILES:${PN}-doc = "${infodir}/texi* \ |
| 81 | ${datadir}/${tex_texinfo} \ |
| 82 | ${mandir}/man1 ${mandir}/man5" |
| 83 | |
| 84 | # Lie about providing the Locale::gettext_xs module. It is not actually built, |
| 85 | # but the code will test for it and if not found use Locale::gettext_pp instead. |
| 86 | # However, this causes a file dependency on perl(Locale::gettext_xs) to be |
| 87 | # generated, which must be satisfied. |
| 88 | RPROVIDES:${PN} += "perl(Locale::gettext_xs)" |
| 89 | |
| 90 | BBCLASSEXTEND = "native nativesdk" |