Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | require gstreamer1.0-plugins-common.inc |
| 2 | require gstreamer1.0-plugins-license.inc |
| 3 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 4 | SUMMARY = "'Bad' GStreamer plugins and helper libraries " |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 5 | HOMEPAGE = "https://gstreamer.freedesktop.org/" |
| 6 | BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues" |
| 7 | |
| 8 | SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-${PV}.tar.xz \ |
| 9 | file://0001-fix-maybe-uninitialized-warnings-when-compiling-with.patch \ |
| 10 | file://0002-avoid-including-sys-poll.h-directly.patch \ |
| 11 | file://0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch \ |
| 12 | " |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "e1798fee2d86127f0637481c607f983293bf0fd81aad70a5c7b47205af3621d8" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/gst-plugins-bad-${PV}" |
| 16 | |
| 17 | LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later" |
| 18 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 19 | |
| 20 | DEPENDS += "gstreamer1.0-plugins-base" |
| 21 | |
| 22 | inherit gobject-introspection |
| 23 | |
| 24 | PACKAGECONFIG ??= " \ |
| 25 | ${GSTREAMER_ORC} \ |
| 26 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ |
| 27 | ${@bb.utils.filter('DISTRO_FEATURES', 'directfb vulkan x11', d)} \ |
| 28 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \ |
| 29 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)} \ |
| 30 | bz2 closedcaption curl dash dtls hls openssl sbc smoothstreaming \ |
| 31 | sndfile ttml uvch264 webp \ |
| 32 | ${@bb.utils.contains('TUNE_FEATURES', 'mx32', '', 'rsvg', d)} \ |
| 33 | " |
| 34 | |
| 35 | PACKAGECONFIG[aom] = "-Daom=enabled,-Daom=disabled,aom" |
| 36 | PACKAGECONFIG[assrender] = "-Dassrender=enabled,-Dassrender=disabled,libass" |
| 37 | PACKAGECONFIG[avtp] = "-Davtp=enabled,-Davtp=disabled,libavtp" |
| 38 | PACKAGECONFIG[bluez] = "-Dbluez=enabled,-Dbluez=disabled,bluez5" |
| 39 | PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2" |
| 40 | PACKAGECONFIG[closedcaption] = "-Dclosedcaption=enabled,-Dclosedcaption=disabled,pango cairo" |
| 41 | PACKAGECONFIG[curl] = "-Dcurl=enabled,-Dcurl=disabled,curl" |
| 42 | PACKAGECONFIG[dash] = "-Ddash=enabled,-Ddash=disabled,libxml2" |
| 43 | PACKAGECONFIG[dc1394] = "-Ddc1394=enabled,-Ddc1394=disabled,libdc1394" |
| 44 | PACKAGECONFIG[directfb] = "-Ddirectfb=enabled,-Ddirectfb=disabled,directfb" |
| 45 | PACKAGECONFIG[dtls] = "-Ddtls=enabled,-Ddtls=disabled,openssl" |
| 46 | PACKAGECONFIG[faac] = "-Dfaac=enabled,-Dfaac=disabled,faac" |
| 47 | PACKAGECONFIG[faad] = "-Dfaad=enabled,-Dfaad=disabled,faad2" |
| 48 | PACKAGECONFIG[fluidsynth] = "-Dfluidsynth=enabled,-Dfluidsynth=disabled,fluidsynth" |
| 49 | PACKAGECONFIG[hls] = "-Dhls=enabled,-Dhls=disabled," |
| 50 | # Pick atleast one crypto backend below when enabling hls |
| 51 | PACKAGECONFIG[nettle] = "-Dhls-crypto=nettle,,nettle" |
| 52 | PACKAGECONFIG[openssl] = "-Dhls-crypto=openssl,,openssl" |
| 53 | PACKAGECONFIG[gcrypt] = "-Dhls-crypto=libgcrypt,,libgcrypt" |
| 54 | # the gl packageconfig enables OpenGL elements that haven't been ported |
| 55 | # to -base yet. They depend on the gstgl library in -base, so we do |
| 56 | # not add GL dependencies here, since these are taken care of in -base. |
| 57 | PACKAGECONFIG[gl] = "-Dgl=enabled,-Dgl=disabled," |
| 58 | PACKAGECONFIG[kms] = "-Dkms=enabled,-Dkms=disabled,libdrm" |
| 59 | PACKAGECONFIG[libde265] = "-Dlibde265=enabled,-Dlibde265=disabled,libde265" |
| 60 | PACKAGECONFIG[libssh2] = "-Dcurl-ssh2=enabled,-Dcurl-ssh2=disabled,libssh2" |
| 61 | PACKAGECONFIG[lcms2] = "-Dcolormanagement=enabled,-Dcolormanagement=disabled,lcms" |
| 62 | PACKAGECONFIG[modplug] = "-Dmodplug=enabled,-Dmodplug=disabled,libmodplug" |
| 63 | PACKAGECONFIG[msdk] = "-Dmsdk=enabled,-Dmsdk=disabled,intel-mediasdk" |
| 64 | PACKAGECONFIG[neon] = "-Dneon=enabled,-Dneon=disabled,neon" |
| 65 | PACKAGECONFIG[openal] = "-Dopenal=enabled,-Dopenal=disabled,openal-soft" |
| 66 | PACKAGECONFIG[opencv] = "-Dopencv=enabled,-Dopencv=disabled,opencv" |
| 67 | PACKAGECONFIG[openh264] = "-Dopenh264=enabled,-Dopenh264=disabled,openh264" |
| 68 | PACKAGECONFIG[openjpeg] = "-Dopenjpeg=enabled,-Dopenjpeg=disabled,openjpeg" |
| 69 | PACKAGECONFIG[openmpt] = "-Dopenmpt=enabled,-Dopenmpt=disabled,libopenmpt" |
| 70 | # the opus encoder/decoder elements are now in the -base package, |
| 71 | # but the opus parser remains in -bad |
| 72 | PACKAGECONFIG[opusparse] = "-Dopus=enabled,-Dopus=disabled,libopus" |
| 73 | PACKAGECONFIG[resindvd] = "-Dresindvd=enabled,-Dresindvd=disabled,libdvdread libdvdnav" |
| 74 | PACKAGECONFIG[rsvg] = "-Drsvg=enabled,-Drsvg=disabled,librsvg" |
| 75 | PACKAGECONFIG[rtmp] = "-Drtmp=enabled,-Drtmp=disabled,rtmpdump" |
| 76 | PACKAGECONFIG[sbc] = "-Dsbc=enabled,-Dsbc=disabled,sbc" |
| 77 | PACKAGECONFIG[sctp] = "-Dsctp=enabled,-Dsctp=disabled" |
| 78 | PACKAGECONFIG[smoothstreaming] = "-Dsmoothstreaming=enabled,-Dsmoothstreaming=disabled,libxml2" |
| 79 | PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1" |
| 80 | PACKAGECONFIG[srt] = "-Dsrt=enabled,-Dsrt=disabled,srt" |
| 81 | PACKAGECONFIG[srtp] = "-Dsrtp=enabled,-Dsrtp=disabled,libsrtp" |
| 82 | PACKAGECONFIG[tinyalsa] = "-Dtinyalsa=enabled,-Dtinyalsa=disabled,tinyalsa" |
| 83 | PACKAGECONFIG[ttml] = "-Dttml=enabled,-Dttml=disabled,libxml2 pango cairo" |
| 84 | PACKAGECONFIG[uvch264] = "-Duvch264=enabled,-Duvch264=disabled,libusb1 libgudev" |
| 85 | # this enables support for stateless V4L2 mem2mem codecs, which is a newer form of |
| 86 | # V4L2 codec; the V4L2 code in -base supports the older stateful V4L2 mem2mem codecs |
| 87 | PACKAGECONFIG[v4l2codecs] = "-Dv4l2codecs=enabled,-Dv4l2codecs=disabled,libgudev" |
| 88 | PACKAGECONFIG[va] = "-Dva=enabled,-Dva=disabled,libva" |
| 89 | PACKAGECONFIG[voaacenc] = "-Dvoaacenc=enabled,-Dvoaacenc=disabled,vo-aacenc" |
| 90 | PACKAGECONFIG[voamrwbenc] = "-Dvoamrwbenc=enabled,-Dvoamrwbenc=disabled,vo-amrwbenc" |
| 91 | PACKAGECONFIG[vulkan] = "-Dvulkan=enabled,-Dvulkan=disabled,vulkan-loader shaderc-native" |
| 92 | PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,wayland-native wayland wayland-protocols libdrm" |
| 93 | PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,libwebp" |
| 94 | PACKAGECONFIG[webrtc] = "-Dwebrtc=enabled,-Dwebrtc=disabled,libnice" |
| 95 | PACKAGECONFIG[webrtcdsp] = "-Dwebrtcdsp=enabled,-Dwebrtcdsp=disabled,webrtc-audio-processing" |
| 96 | PACKAGECONFIG[zbar] = "-Dzbar=enabled,-Dzbar=disabled,zbar" |
| 97 | PACKAGECONFIG[x11] = "-Dx11=enabled,-Dx11=disabled,libxcb libxkbcommon" |
| 98 | PACKAGECONFIG[x265] = "-Dx265=enabled,-Dx265=disabled,x265" |
| 99 | |
| 100 | GSTREAMER_GPL = "${@bb.utils.filter('PACKAGECONFIG', 'faad resindvd x265', d)}" |
| 101 | |
| 102 | EXTRA_OEMESON += " \ |
| 103 | -Ddoc=disabled \ |
| 104 | -Daes=enabled \ |
| 105 | -Dcodecalpha=enabled \ |
| 106 | -Ddecklink=enabled \ |
| 107 | -Ddvb=enabled \ |
| 108 | -Dfbdev=enabled \ |
| 109 | -Dipcpipeline=enabled \ |
| 110 | -Dshm=enabled \ |
| 111 | -Dtranscode=enabled \ |
| 112 | -Dandroidmedia=disabled \ |
| 113 | -Dapplemedia=disabled \ |
| 114 | -Dasio=disabled \ |
| 115 | -Dbs2b=disabled \ |
| 116 | -Dchromaprint=disabled \ |
| 117 | -Dd3dvideosink=disabled \ |
| 118 | -Dd3d11=disabled \ |
| 119 | -Ddirectsound=disabled \ |
| 120 | -Ddts=disabled \ |
| 121 | -Dfdkaac=disabled \ |
| 122 | -Dflite=disabled \ |
| 123 | -Dgme=disabled \ |
| 124 | -Dgs=disabled \ |
| 125 | -Dgsm=disabled \ |
| 126 | -Diqa=disabled \ |
| 127 | -Dkate=disabled \ |
| 128 | -Dladspa=disabled \ |
| 129 | -Dldac=disabled \ |
| 130 | -Dlv2=disabled \ |
| 131 | -Dmagicleap=disabled \ |
| 132 | -Dmediafoundation=disabled \ |
| 133 | -Dmicrodns=disabled \ |
| 134 | -Dmpeg2enc=disabled \ |
| 135 | -Dmplex=disabled \ |
| 136 | -Dmusepack=disabled \ |
| 137 | -Dnvcodec=disabled \ |
| 138 | -Dopenexr=disabled \ |
| 139 | -Dopenni2=disabled \ |
| 140 | -Dopenaptx=disabled \ |
| 141 | -Dopensles=disabled \ |
| 142 | -Donnx=disabled \ |
| 143 | -Dqroverlay=disabled \ |
| 144 | -Dsoundtouch=disabled \ |
| 145 | -Dspandsp=disabled \ |
| 146 | -Dsvthevcenc=disabled \ |
| 147 | -Dteletext=disabled \ |
| 148 | -Dwasapi=disabled \ |
| 149 | -Dwasapi2=disabled \ |
| 150 | -Dwildmidi=disabled \ |
| 151 | -Dwinks=disabled \ |
| 152 | -Dwinscreencap=disabled \ |
| 153 | -Dwpe=disabled \ |
| 154 | -Dzxing=disabled \ |
| 155 | " |
| 156 | |
| 157 | export OPENCV_PREFIX = "${STAGING_DIR_TARGET}${prefix}" |
| 158 | |
| 159 | ARM_INSTRUCTION_SET:armv4 = "arm" |
| 160 | ARM_INSTRUCTION_SET:armv5 = "arm" |
| 161 | |
| 162 | FILES:${PN}-freeverb += "${datadir}/gstreamer-1.0/presets/GstFreeverb.prs" |
| 163 | FILES:${PN}-opencv += "${datadir}/gst-plugins-bad/1.0/opencv*" |
| 164 | FILES:${PN}-transcode += "${datadir}/gstreamer-1.0/encoding-profiles" |
| 165 | FILES:${PN}-voamrwbenc += "${datadir}/gstreamer-1.0/presets/GstVoAmrwbEnc.prs" |