Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame^] | 1 | SUMMARY = "Simple DirectMedia Layer truetype font library" |
| 2 | SECTION = "libs" |
| 3 | DEPENDS = "libsdl2 freetype virtual/egl" |
| 4 | LICENSE = "Zlib" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=771dca8728b18d39b130e19b36514371" |
| 6 | |
| 7 | SRC_URI = " \ |
| 8 | git://github.com/libsdl-org/SDL_ttf.git;branch=release-2.20.x;protocol=https \ |
| 9 | git://github.com/libsdl-org/freetype.git;branch=VER-2-12-1-SDL;destsuffix=git/external/freetype;name=freetype;protocol=https \ |
| 10 | git://github.com/libsdl-org/harfbuzz.git;branch=2.9.1-SDL;destsuffix=git/external/harfbuzz;name=harfbuzz;protocol=https \ |
| 11 | file://automake_foreign.patch \ |
| 12 | " |
| 13 | SRCREV = "0a652b598625d16ea7016665095cb1e9bce9ef4f" |
| 14 | SRCREV_freetype = "6fc77cee03e078e97afcee0c0e06a2d3274b9a29" |
| 15 | SRCREV_harfbuzz = "6022fe2f68d028ee178284f297b3902ffdf65b03" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit autotools pkgconfig features_check |
| 20 | |
| 21 | # links to libGL.so |
| 22 | REQUIRED_DISTRO_FEATURES += "opengl" |
| 23 | |
| 24 | do_configure:prepend() { |
| 25 | # Removing these files fixes a libtool version mismatch. |
| 26 | MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4" |
| 27 | |
| 28 | for i in ${MACROS}; do |
| 29 | rm -f ${S}/acinclude/$i |
| 30 | done |
| 31 | } |
| 32 | ASNEEDED = "" |