Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame^] | 1 | SUMMARY = "a fast C/C++ compiler cache" |
| 2 | DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \ |
| 3 | by caching the result of previous compilations and detecting when the \ |
| 4 | same compilation is being done again. Supported languages are C, C\+\+, \ |
| 5 | Objective-C and Objective-C++." |
| 6 | HOMEPAGE = "http://ccache.samba.org" |
| 7 | SECTION = "devel" |
| 8 | |
| 9 | LICENSE = "GPL-3.0-or-later" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=7a19377a02749d8a1281ed608169b0ee" |
| 11 | |
| 12 | DEPENDS = "zstd" |
| 13 | |
| 14 | SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz \ |
| 15 | file://0001-xxhash.h-Fix-build-with-gcc-12.patch \ |
| 16 | file://0001-Include-time.h-for-time_t.patch \ |
| 17 | file://0002-config-Include-sys-types.h-for-mode_t-defintion.patch \ |
| 18 | " |
| 19 | SRC_URI[sha256sum] = "6a746a9bed01585388b68e2d58af2e77741fc8d66bc360b5a0b4c41fc284dafe" |
| 20 | |
| 21 | UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/" |
| 22 | |
| 23 | inherit cmake |
| 24 | |
| 25 | PATCHTOOL = "patch" |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |
| 28 | |
| 29 | PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc" |
| 30 | PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis" |