Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "C bindings for apps which will manipulate JSON data" |
| 2 | DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C." |
| 3 | HOMEPAGE = "https://github.com/json-c/json-c/wiki" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2" |
| 6 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame^] | 7 | SRC_URI = " \ |
| 8 | https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \ |
| 9 | file://0001-Fix-build-with-clang-15.patch \ |
| 10 | file://run-ptest \ |
| 11 | " |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 12 | SRC_URI[sha256sum] = "8e45ac8f96ec7791eaf3bb7ee50e9c2100bbbc87b8d0f1d030c5ba8a0288d96b" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 14 | UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/tags" |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 15 | UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+)-\d+" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 17 | RPROVIDES:${PN} = "libjson" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame^] | 19 | inherit cmake ptest |
| 20 | |
| 21 | do_install_ptest() { |
| 22 | install -d ${D}/${PTEST_PATH}/tests |
| 23 | install ${B}/tests/test* ${D}/${PTEST_PATH}/tests |
| 24 | install ${S}/tests/*.test ${D}/${PTEST_PATH}/tests |
| 25 | install ${S}/tests/*.expected ${D}/${PTEST_PATH}/tests |
| 26 | install ${S}/tests/test-defs.sh ${D}/${PTEST_PATH}/tests |
| 27 | install ${S}/tests/valid*json ${D}/${PTEST_PATH}/tests |
| 28 | } |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |