Brad Bishop | a6bd1e9 | 2016-09-06 23:25:16 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC for OpenPOWER - Applications" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit packagegroup |
Brad Bishop | 02f9a52 | 2018-03-09 16:51:57 -0500 | [diff] [blame] | 5 | inherit obmc-phosphor-utils |
Brad Bishop | a6bd1e9 | 2016-09-06 23:25:16 -0400 | [diff] [blame] | 6 | |
| 7 | PROVIDES = "${PACKAGES}" |
| 8 | PACKAGES = " \ |
Brad Bishop | a6bd1e9 | 2016-09-06 23:25:16 -0400 | [diff] [blame] | 9 | ${PN}-chassis \ |
| 10 | ${PN}-fans \ |
| 11 | ${PN}-flash \ |
| 12 | ${PN}-system \ |
| 13 | " |
| 14 | |
Brad Bishop | a6bd1e9 | 2016-09-06 23:25:16 -0400 | [diff] [blame] | 15 | PROVIDES += "virtual/obmc-chassis-mgmt" |
| 16 | PROVIDES += "virtual/obmc-fan-mgmt" |
| 17 | PROVIDES += "virtual/obmc-flash-mgmt" |
| 18 | PROVIDES += "virtual/obmc-system-mgmt" |
| 19 | |
Brad Bishop | a6bd1e9 | 2016-09-06 23:25:16 -0400 | [diff] [blame] | 20 | RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-mgmt" |
| 21 | RPROVIDES_${PN}-fans += "virtual-obmc-fan-mgmt" |
| 22 | RPROVIDES_${PN}-flash += "virtual-obmc-flash-mgmt" |
| 23 | RPROVIDES_${PN}-system += "virtual-obmc-system-mgmt" |
| 24 | |
Brad Bishop | a6bd1e9 | 2016-09-06 23:25:16 -0400 | [diff] [blame] | 25 | SUMMARY_${PN}-chassis = "OpenPOWER Chassis" |
| 26 | RDEPENDS_${PN}-chassis = " \ |
| 27 | obmc-button-power \ |
| 28 | obmc-button-reset \ |
| 29 | obmc-control-chassis \ |
Brad Bishop | a6bd1e9 | 2016-09-06 23:25:16 -0400 | [diff] [blame] | 30 | obmc-op-control-power \ |
Matt Spinler | 1e7bfcc | 2017-03-06 11:06:27 -0600 | [diff] [blame] | 31 | obmc-host-failure-reboots \ |
Brad Bishop | a6bd1e9 | 2016-09-06 23:25:16 -0400 | [diff] [blame] | 32 | " |
Matt Spinler | cf92a50 | 2017-03-08 13:53:51 -0600 | [diff] [blame] | 33 | #Pull in obmc-fsi on all P9 OpenPOWER systems |
Matt Spinler | 25b36e2 | 2017-04-07 14:21:33 -0500 | [diff] [blame] | 34 | RDEPENDS_${PN}-chassis += "${@mf_enabled(d, 'op-fsi', 'op-fsi')}" |
Brad Bishop | a6bd1e9 | 2016-09-06 23:25:16 -0400 | [diff] [blame] | 35 | |
Matt Spinler | cbb1d07 | 2017-04-28 08:17:23 -0500 | [diff] [blame] | 36 | #Pull in p9-cfam-override on all P9 OpenPOWER systems |
| 37 | RDEPENDS_${PN}-chassis += "${@mf_enabled(d, 'p9-cfam-override', 'p9-cfam-override')}" |
| 38 | |
Brad Bishop | 32aa6d7 | 2017-01-11 12:57:11 -0500 | [diff] [blame] | 39 | SUMMARY_${PN}-fans = "OpenPOWER Fans" |
Brad Bishop | a6bd1e9 | 2016-09-06 23:25:16 -0400 | [diff] [blame] | 40 | RDEPENDS_${PN}-fans = " \ |
Brad Bishop | a6bd1e9 | 2016-09-06 23:25:16 -0400 | [diff] [blame] | 41 | obmc-control-fan \ |
| 42 | " |
| 43 | |
| 44 | SUMMARY_${PN}-flash = "OpenPOWER Flash" |
| 45 | RDEPENDS_${PN}-flash = " \ |
Brad Bishop | 09806a5 | 2018-03-09 00:40:41 -0500 | [diff] [blame] | 46 | obmc-flash-bios \ |
| 47 | obmc-mgr-download \ |
| 48 | obmc-op-flasher \ |
Brad Bishop | a6bd1e9 | 2016-09-06 23:25:16 -0400 | [diff] [blame] | 49 | " |
Brad Bishop | 09806a5 | 2018-03-09 00:40:41 -0500 | [diff] [blame] | 50 | RDEPENDS_${PN}-flash_df-openpower-ubi-fs = " \ |
Brad Bishop | 09806a5 | 2018-03-09 00:40:41 -0500 | [diff] [blame] | 51 | openpower-software-manager \ |
| 52 | " |
| 53 | |
Brad Bishop | a6bd1e9 | 2016-09-06 23:25:16 -0400 | [diff] [blame] | 54 | SUMMARY_${PN}-system = "OpenPOWER System" |
| 55 | RDEPENDS_${PN}-system = " \ |
Joel Stanley | f0ee32d | 2018-05-11 17:51:47 +0930 | [diff] [blame] | 56 | hostboot-settings \ |
Andrew Jeffery | 28e4ea7 | 2017-10-19 12:25:57 +1030 | [diff] [blame] | 57 | pdbg \ |
Brad Bishop | a6bd1e9 | 2016-09-06 23:25:16 -0400 | [diff] [blame] | 58 | " |